WordPress.org

Ready to get started?Download WordPress

Forums

WP Photo Album Plus
[resolved] Comments on widget don't work (5 posts)

  1. sjomar
    Member
    Posted 1 year ago #

    After a fresh install of wordpress & the wppa plugin all seems to work fine, hoewever after fidling with some settings of wppa all comments made via the widgets doesn't work anymore. Resetting the settings off wppa to default doesn't matter anymore.
    The comment box does show up, but after filling in some text it just returns to the picture. Comments given via the "photo" page and slideshow does still work strangely enough.
    Any idea hoe to proceed to find out what's wrong? And how to resolve it?

    My site is http://sjomar.idef1x.net

    NB: I am using plugin version 4.7.16

    http://wordpress.org/extend/plugins/wp-photo-album-plus/

  2. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 1 year ago #

    During investigation on this problem, the site is changing. Does the problem still exist and what did you change?

  3. sjomar
    Member
    Posted 1 year ago #

    Yes sorry for that. I was just playing with some other theme settings, while I saw a comment get through from you.
    I still encounter the same problems though, so I assume you made the comment via the "photo" page/slideshow?

    I'll stop playing with the site for now ;)
    Thanks for the support.

  4. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 1 year ago #

    I think i fixed it, please try it before i release it.
    Patch wppa-functions.php:

    From line 1703 to 1710 it reads:

    if ($album) $returnurl .= 'wppa-album='.$album.'&';
    $cover = wppa_get_get('cover');
    if ($cover) $returnurl .= 'wppa-cover='.$cover.'&';
    $slide = wppa_get_get('slide');
    if ($slide !== false) $returnurl .= 'wppa-slide&';
    $occur = wppa_get_get('occur');
    if ($occur) $returnurl .= 'wppa-occur='.$occur.'&';
    $returnurl .= 'wppa-photo='.$id;

    Change the first line into:

    if ( $album !== false ) $returnurl .= 'wppa-album='.$album.'&';

    i.e. $album => $album !== false
    and add after 1709: if ($occur) $returnurl .= 'wppa-occur='.$occur.'&'; the following 4 lines:

    $lasten = wppa_get_get('lasten');
    if ( $lasten ) $returnurl .= 'wppa-lasten='.$lasten.'&';
    $topten = wppa_get_get('topten');
    if ( $topten ) $returnurl .= 'wppa-topten='.$topten.'&';

    the next line is unchanged: $returnurl .= 'wppa-photo='.$id;

  5. sjomar
    Member
    Posted 1 year ago #

    Wauw that's quick!
    Proves I was right about changing from Nextgen Gallery to WPPA! ;)

    Anyway it's indeed working now. Great! Thanks for the quick response and fix.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic