WordPress.org

Ready to get started?Download WordPress

Forums

WP-Paginate
[resolved] 404 on every page (except the first) (3 posts)

  1. NQbbe
    Member
    Posted 4 years ago #

    I've installed wp-paginate on a new wordpress blog I'm setting up. However the second I click page 2 (or any one really) I get a 404.

    It seems wordpress doesn't map the URL properly to index.php, when it's /page/2

    Did I miss some settings or should I add some extra code to index.php ?

    I already have this at the top:

    $paged = (get_query_var('paged')) ? get_query_var('paged') : 1;
    query_posts('posts_per_page=3&paged=' . $paged);

    Permalinks are set to: /%category%/%postname%

    Thanks a lot in advance :-)

    http://wordpress.org/extend/plugins/wp-paginate/

  2. NQbbe
    Member
    Posted 4 years ago #

    My bad, I should use the global posts_per_page setting, then everything works like a charm:

    $paged = (get_query_var('paged')) ? get_query_var('paged') : 1;
    $postsPerPage = get_option('posts_per_page');
    query_posts('posts_per_page=' . $postsPerPage . '&paged=' . $paged);
  3. lluna_online
    Member
    Posted 3 years ago #

    I have the same problem... The plugin works but not on category pages. When you click in the second page it goes away to the second general page, not to the second category page. The installation instructions don't help me...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic