WordPress.org

Ready to get started?Download WordPress

Forums

WP-PageNavi
Page navigation links calling a search query? (42 posts)

  1. Rafael Fischmann
    Member
    Posted 3 years ago #

    This began a few days ago and I have no idea what to do.

    http://macmagazine.com.br

    Users are telling me the links to page 2, 3, etc. are calling random search queries.

    Does anyone know how to fix this?!

  2. scribu
    Member
    Plugin Author

    Posted 3 years ago #

    It is probably caused by one of your plugins, i.e. one related to searching.

  3. Farwalker
    Member
    Posted 3 years ago #

    Rafael,

    I'm getting the exact same issue on my blog. Just started to be an issue with the past week or so. In the Google Webmaster Tools, Google is started to display those links as 403 Crawl Errors. Though the issue appears and disappears at random.

    Scribu, below are the plugins installed for my blog. Would you have any ideas on any potential conflicts? I could then mess around with activating and deactivating until I figure out what's causing it.

    Though, I haven't installed any new plugins for a while now and up until a few weeks ago there were no issues with the WP-Pagenavi plugin displaying random searches.

    Here's an example of one: http://www.productscoop.com/page/10/?option=com_product&controller=..%2F..%2F..%2F..%2F..%2F..%2F..%2F..%2F..%2F..%2F..%2F..%2F..%2F..%2F..%2Fproc%2Fself%2Fenviron%00

    Active Plugins:

    Akismet
    All in One SEO Pack
    Contact Form 7
    Display widgets
    Google Analyticator
    Google XML Sitemaps
    Pretty Link (Lite Version)
    Simple 301 Redirects
    WP-PageNavi
    WP Minify
    WP Super Cache

  4. scribu
    Member
    Plugin Author

    Posted 3 years ago #

    @Farwalker: It looks like your site has been infected by malware.

  5. BilalBhatti
    Member
    Posted 3 years ago #

    Same problem! Its the problem of WP-PageNavi! Uninstalling as it is extremely bad for SEO!

  6. BilalBhatti
    Member
    Posted 3 years ago #

    @Above All: Remove Google Analytics and you will be fine!

  7. Rafael Fischmann
    Member
    Posted 3 years ago #

    Just switched to this plugin, guys:

    http://wordpress.org/extend/plugins/wp-paginate/

    I hope it doesn't have the same bug.

  8. Rafael Fischmann
    Member
    Posted 3 years ago #

    Didn't work, the bug is not related to the pagination plugin. Bugger! :(

  9. BilalBhatti
    Member
    Posted 3 years ago #

    I am telling you its the issue of WP-Super Cache with Google Analytics. Its confirmed.

  10. Rafael Fischmann
    Member
    Posted 3 years ago #

    I'll notify WP-Super Cache's developer and see what does he say. I can't simply get rid of Google Analytics.

  11. BilalBhatti
    Member
    Posted 3 years ago #

    I am in contact with him directly on Twitter. I will also report the issue. Again the issue is with Google Analytics NEW code. Some people resolved it by adding the Analytics code in footer (Below page navigation links)

  12. BilalBhatti
    Member
    Posted 3 years ago #

    If you will disable the WP-Super Cache, you will see that it wont cache any Analytics query.

    Twitter: http://twitter.com/BilalBhatti
    Website: http://bilalbhatti.com

  13. Rafael Fischmann
    Member
    Posted 3 years ago #

    I believe in you, because I only see the problem when I visit my site from another browser in which I'm not logged in to WordPress (e.g., accessing pages with cache enabled).

  14. BilalBhatti
    Member
    Posted 3 years ago #

    You exactly got my point. Its a terrible issue for SEO as it is increasing the duplicate content by accessing the same thing though different URLs. You can temporarily block this through robots.txt

  15. Rafael Fischmann
    Member
    Posted 3 years ago #

    You mean block Google and other search engines?!

  16. BilalBhatti
    Member
    Posted 3 years ago #

    Yes, you can block Google from indexing that query URL. It will solve the duplicate content issue.

    User-agent: Googlebot
    Disallow: /*?*

  17. BilalBhatti
    Member
    Posted 3 years ago #

    To be more precise

    User-agent: Googlebot
    Disallow: *com_product*

  18. Rafael Fischmann
    Member
    Posted 3 years ago #

    I'll wait for Donncha's reply on the subject before doing that. Maybe there's a quick fix — I hope so, at least.

  19. Donncha O Caoimh
    Member
    Posted 3 years ago #

    Supercache doesn't cache queries with GET parameters. Where are your visitors finding those links?

  20. Rafael Fischmann
    Member
    Posted 3 years ago #

    Wooa, same second! LOL.

    Donncha, it's the page navigation links, you can find them on the bottom of my homepage:

    http://macmagazine.com.br/

  21. Donncha O Caoimh
    Member
    Posted 3 years ago #

    So when someone clicks on /page/10/ they get /page/10/?option=com.... but the url is "/page/10/"? Check the supercache directory - wp-content/cache/supercache/macmagazine.com.br/page/10/ etc and verify if the correct page has been cached.

  22. Rafael Fischmann
    Member
    Posted 3 years ago #

    There's nothing inside the /wp-content/cache/supercache/macmagazine.com.br/page/ directory. o.0

  23. Donncha O Caoimh
    Member
    Posted 3 years ago #

    I just requested page 7 and the headers showed it was served by PHP and was a supercache file:

    WP-Super-Cache: Served supercache file from PHP

    The search results might be cached by Supercache but something else is generating that content. Supercache is only caching what your site has produced.

  24. Rafael Fischmann
    Member
    Posted 3 years ago #

    I'm not an expert in this, but I believe you're not getting the point. I've just access my site via Safari (in which I'm not logged in and I can browse with cache enabled) and saw the problem again. The page navigation links in the home page are now bundled with a search query for "Light Peak".

    I browsed to the /wp-content/cache/supercache/macmagazine.com.br/page/ folder again and there are now 3 sub-folders inside it: /2/, /3/ and /4/. That's it.

    I browsed through those pages in my site and they were all cached correctly. The page navigation links in them are ok. The problem resides in the homepage.

    There's some kind of conflict going on in the way the HOMEPAGE generates those page navigation links. Whenever you get to page 2, 3, 4 and so on, it looks ok to me.

  25. BilalBhatti
    Member
    Posted 3 years ago #

    @donncha Yes @Rafael is right. Its either the issue of WP Super Cache or its the new code of Google Analytics. Removing either of them solves the issue. Different websites are using this hole in PageNavigation plugin for spamming purpose.

  26. Donncha O Caoimh
    Member
    Posted 3 years ago #

    So spammers take advantage of a problem in another plugin to create a cached page with incorrect or spammy content? I'm not sure how Supercache could stop that happening.

    If the problem stops when either of those plugins is removed then it's likely a problem in that Google Analytics plugin. You'd probably have the same thing happen no matter what page caching plugin was used.

  27. Rafael Fischmann
    Member
    Posted 3 years ago #

    I personally don't use any Google Analytics plugin. The code was added to my template manually, copying and pasting from what Google tells us to do.

    So, as I said, I simply can't get rid of it. Analytics is my main statistics' system for my website.

  28. BilalBhatti
    Member
    Posted 3 years ago #

    @donncha: Yeah, you will find some websites with PageNavi links like this:

    http://www.example.com/page/10/?option=com_product&controller=..%2F..%2F..%2F..%2F..%2F..%2F..%2F..%2F..%2F..%2F..%2F..%2F..%2F..%2F..%2Fwww.spamsite.com..%2F..%2F

    2ndly, yes its the issue with Google Analytics. But one thing is 100% confirmed, when we are logged in, there is no such links because we are not served the cached pages. Whenever we log out of WP admin account, we are served with cache and we get the issue. 2ndly, i never checked if its the issue with PRE-LOADING feature of WP-Super cache or not. If we do not pre-load the cache, the problem may not occur.

  29. Donncha O Caoimh
    Member
    Posted 3 years ago #

    I don't think you'll find those links on preloaded pages as they're generated by the server itself. I suspect spammers are injecting those links in somehow, knowing they'll be cached. There's not much Supercache can do.

  30. Rafael Fischmann
    Member
    Posted 3 years ago #

    So there's really no solution to this problem? :(

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic