WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP-PageNavi] Issue with default CSS (8 posts)

  1. Liesl Fawcett
    Member
    Posted 4 years ago #

    Hi, I'm having a problem with the default CSS... I edit it my way to have a background for each "block" (Like for "Page 1 of 3", etc) but there default border is still there, even after I remove it, and the text looks messed up (not aligned properly, even though it worked fine with version 2.61). Any idea why this is?

    http://wordpress.org/extend/plugins/wp-pagenavi/

  2. scribu
    Member
    Posted 4 years ago #

    Copy the new pagenavi-css.css file over to your theme directory and make your modifications on that.

  3. Liesl Fawcett
    Member
    Posted 4 years ago #

    That didn't work either..

  4. scribu
    Member
    Posted 4 years ago #

    Paste the URL to your site.

  5. Liesl Fawcett
    Member
    Posted 4 years ago #

    My site is under construction so I took a screenshot instead... if you need to see the page source I can copy part of it and paste it here too.

    http://i938.photobucket.com/albums/ad221/liesl020609/pagenavi.png

    This is the modified CSS:

    .wp-pagenavi {padding-top:5px;margin-bottom:60px;}

    .wp-pagenavi a, .wp-pagenavi a:link, .wp-pagenavi span {
    background:url(/wp-content/themes/concise/images/bg_pagelink.png) no-repeat;
    color:#555;
    width:31px;
    height:27px;
    display:block;
    float:left;
    font:0.9em verdana;
    padding-top:6px;
    margin-right:5px;
    text-align:center;
    }
    .wp-pagenavi a:visited {
    background:url(/wp-content/themes/concise/images/bg_pagelink.png) no-repeat;
    color:#555;
    width:31px;
    height:27px;
    display:block;
    float:left;
    font:0.9em verdana;
    padding-top:6px;
    margin-right:5px;
    text-align:center;
    }
    .wp-pagenavi a:hover {
    background:#372529;
    color:#ffffff;
    text-decoration:none;
    background:url(/wp-content/themes/concise/images/bg_current_pagelink.gif) no-repeat;
    }
    .wp-pagenavi a:active {
    background:url(/wp-content/themes/concise/images/bg_pagelink.png) no-repeat;
    color:#555;
    width:31px;
    height:27px;
    display:block;
    float:left;
    font:0.9em verdana;
    padding-top:6px;
    margin-right:5px;
    text-align:center;
    }
    .wp-pagenavi span.pages {
    background:url(/wp-content/themes/concise/images/bg_pagetext.gif) no-repeat;
    color:#fff;
    width:94px;
    height:27px;
    display:block;
    float:left;
    font:0.9em verdana;
    padding-top:6px;
    margin-right:5px;
    text-align:center;
    }
    .wp-pagenavi span.current {
    background:url(/wp-content/themes/concise/images/bg_pagelink.png) no-repeat;
    color:#555;
    width:31px;
    height:27px;
    display:block;
    float:left;
    font:0.9em verdana;
    padding-top:6px;
    margin-right:5px;
    text-align:center;
    }
    .wp-pagenavi span.extend {
    background:url(/wp-content/themes/concise/images/bg_pagelink.png) no-repeat;
    color:#555;
    width:31px;
    height:27px;
    display:block;
    float:left;
    font:0.9em verdana;
    padding-top:6px;
    margin-right:5px;
    text-align:center;
    }

  6. scribu
    Member
    Posted 4 years ago #

    Uncheck the "Use pagenavi-css.css" checkbox in Wp-Admin -> Settings -> PageNavi.

    If that doesn't work, try adding this:

    .wp-pagenavi * {border: 0 !important}

  7. Liesl Fawcett
    Member
    Posted 4 years ago #

    That got rid of the border but I had to use the !important tag for everything else and I had to use negative numbers (like padding:-5px;) to adjust the text properly. It was strange that I had to do that but at least it worked. Thanks!

  8. Liesl Fawcett
    Member
    Posted 4 years ago #

    That got rid of the border but I had to use the !important tag for everything else and I had to use negative numbers (like padding:-5px;) to adjust the text properly. It was strange that I had to do that but at least it worked. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic