WordPress.org

Ready to get started?Download WordPress

Forums

WP-PageNavi
[resolved] Can't activate plugin: Parse Error. (7 posts)

  1. activeseven
    Member
    Posted 3 years ago #

    Brand new installation of WP, there is only one plugin I installed before this and it was wp-syntax. Not that that would have anything to do with a parse error.

    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /nfs/c03/h04/mnt/57735/domains/blog.activeseven.com/html/wp-content/plugins/wp-pagenavi/scb/load.php on line 12

  2. scribu
    Member
    Plugin Author

    Posted 3 years ago #

  3. bergamasque
    Member
    Posted 3 years ago #

    Hi,

    I'm having this same issue. Strangely, I have 6 different installs of WP on the server, and the plugin works flawlessly on 2 of them, but I get the parse error when trying to activate the plugin on the 4 others.

    When I checked the PHP version, it gave me this text "string(5) "4.4.8"". So I guess that's the version of PHP I have. I wonder, though, that it works in some of my installs, and not others... Is there no way to make page-navi work with lesser versions than PHP 5 ?

  4. scribu
    Member
    Plugin Author

    Posted 3 years ago #

    There's no point in that, since WordPress itself will require PHP5 pretty soon:

    http://wordpress.org/news/2010/07/eol-for-php4-and-mysql4/

  5. spoonjab
    Member
    Posted 3 years ago #

    I was unable to activate or deactivate plugins from my admin panel. Also, plugins like Sexy Bookmarks stopped working. A general Google search lead me here and hinted at the problem wp-pagenavi. I wouldn't have thought this plugin was the problem because it worked fine on the website.

    After deleting the wp-pagenavi plugin folder via FTP, everything works just find. Using WordPress 3.0.1

  6. FreeDigger
    Member
    Posted 3 years ago #

    I put var_dump(PHP_VERSION);
    an I get this
    string(6) "5.2.14"
    Warning: Cannot modify header information - headers already sent by (output started at /home/aquapech/public_html/wp-config.php:1) in /home/aquapech/public_html/wp-includes/pluggable.php on line 890

    Warning: Cannot modify header information - headers already sent by (output started at /home/aquapech/public_html/wp-config.php:1) in /home/aquapech/public_html/wp-includes/pluggable.php on line 890

    so I have php5 but this plug do not activate....

  7. FreeDigger
    Member
    Posted 3 years ago #

    sorry, plug is working, thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic