WordPress.org

Ready to get started?Download WordPress

Forums

WP-PageNavi
2.73 Not Showing Page 2 (4 posts)

  1. cianofarmer
    Member
    Posted 3 years ago #

    i can not get this to roll over to page two and show the listed product

    star on page one
    http://www.cianofarmer.com/?cat=7

    then click page two this shows up
    No Results Found
    The page you requested could not be found. Try refining your search, or use the navigation above to locate the post.
    http://www.cianofarmer.com/?cat=7&paged=2

    he is the index.php from the theme

    <?php include(TEMPLATEPATH . '/includes/breadcrumbs.php'); ?>

    <div id="main-area">
    <div id="main-content" class="clearfix">

    <?php global $query_string;
    if (is_category()) query_posts($query_string . "&showposts=$post_number&paged=$paged&cat=$cat");
    else query_posts($query_string . "&showposts=$post_number&paged=$paged"); ?>

    <div id="left-column">
    <?php $i = 1; ?>

    <?php if (have_posts()) : while (have_posts()) : the_post(); ?>
    <?php include(TEMPLATEPATH . '/includes/entry.php'); ?>
    <?php $i++; ?>
    <?php endwhile; ?>
    <?php if (($i-1) % 3 <> 0) echo('<div class="clear"></div>'); ?>
    <?php if(function_exists('wp_pagenavi')) { wp_pagenavi(); }
    else { ?>
    <?php include(TEMPLATEPATH . '/includes/navigation.php'); ?>
    <?php } ?>
    <?php else : ?>
    <?php include(TEMPLATEPATH . '/includes/no-results.php'); ?>
    <?php endif; wp_reset_query(); ?>
    </div> <!-- #left-column -->

    <?php get_sidebar(); ?>

    <?php get_footer(); ?>

    please help

  2. verticalimit
    Member
    Posted 3 years ago #

    Hello,

    i have the same pb: i get a mistake for the page 2.
    How did you manage to fix your pb pls?

    Thanks,

  3. cianofarmer
    Member
    Posted 3 years ago #

    i was told to do this and it worked...

    see below

    Go to WP-Admin / Settings / Reading and set Blog pages to show at most... post to 6

  4. verticalimit
    Member
    Posted 3 years ago #

    Thanks :)
    Unfortunately i did not work for me.
    I tried also with 4 and 5.
    But still was the same.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic