WordPress.org

Ready to get started?Download WordPress

Forums

WP Orbit Slider
Override options (6 posts)

  1. scottdaris
    Member
    Posted 2 years ago #

    Thanks for providing such a great slider. It worked instantly - I love when that happens. However, I would like to override some of the options and the ones in the dropdowns stop at certain points. I would like to set the Slider Time Delay to 8 seconds (8000ms) and the startClockOnMouseOut to true. I know how to change settings in the .js files named jquery.orbit-1.3.0.js and jquery.orbit-1.3.0.min.js but then the changes aren't reflected when I go back to the WP Orbit Slider Options in the dashboard. Then, of course, they wouldn't stick since your dropdowns stop at limited options. Maybe in the future you shouldn't even have dropdowns and just let people type in whatever values they want. Anyways, please let me know how I can make my manual settings sticky. Thanks!

    http://wordpress.org/extend/plugins/wp-orbit-slider/

  2. scottdaris
    Member
    Posted 2 years ago #

    Well, I figured it out. I just changed the integer advancement in includes/options_page.php to:

    advanceSpeed : ($i=500; $i<=10000; $i+= 500) and

    animationSpeed : ($i=200; $i<=10000; $i+= 200)

    so now I don't have to hard-code the .js files to get more options in the dropdowns.

    This is what happens when a person stays up until 8am on major caffeine :D

  3. virtualpudding
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks for the kind words.
    We've all been there (8am and loaded!) Happy to hear you got a fix.
    I'll review the settings in the next update.

  4. gary.upham
    Member
    Posted 1 year ago #

    Hey guys, I was also wanting to make my slide last for about 15 seconds and I put this in the options_page.php file

    <?php for($i=1000; $i<=15000; $i+= 1000): ?>

    It shows up on my options page now and has a max of 15000 with integers of 1000, but when I select 15000, I hit save settings and when the page refreshes, it has 4000 selected.

    Is there something else that I am missing that is causing this change to not stick?

    Thank you for the find too Scott.

    - Gary

  5. scottdaris
    Member
    Posted 1 year ago #

    Hmm, I don't know. Maybe there's a global setting for the whole slideshow that's overriding it? Or maybe browser cache or your WP cache? I'm just learning all this stuff myself :)

  6. gary.upham
    Member
    Posted 1 year ago #

    Not sure ... does it help to know that up until 8000, it will stick, but if I try and go any over 8000 when selecting in the wp backend, I hit save and it goes back to 4000.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic