WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP-OpenID] Fatal error on reactivation (7 posts)

  1. Branch
    Member
    Posted 5 years ago #

    I have tried upgrading from version 2.1.9 to 2.2.0 and 2.2.1, and, in both cases, upon reactivating the plugin I get a note telling me that the plugin could not be reactivated because it caused a fatal error.

    The plugin appears to be activated, but when I attempt to authenticate through it I am returned to my site un-authenticated.

    The Settings page for the plugin does not show any errors. All my tables are present, all the file paths are correct, there are no problems showing up in the status box there.

    I'm running WP 2.6 and my server runs PHP 4.4.8 and MySQL 5.0.45, if that makes a difference.

    I'm not having any problems just using 2.1.9, so this isn't terribly urgent, but it would be nice to be able to upgrade.

    http://wordpress.org/extend/plugins/openid/

  2. Anonymous
    Unregistered
    Posted 5 years ago #

    I have the same symptoms. PHP version is 5.2.6 and MySQL is 4.1.22.

  3. oeconomist
    Member
    Posted 5 years ago #

    Likewise. I have WordPress version 2.6, PHP 4.4.7, and MySQL 4.1.22-standard. Wp-OpenID 2.19 works; versions 2.20 and 2.21 have fatal errors on reactivation.

    My 'blog is not installed in the root directory of my domain. Meanwhile, my OpenID is associated with the domain, rather than with the 'blog. How 'bout yours, Branch and jaxidian?

  4. perlmunger
    Member
    Posted 5 years ago #

    I'm not sure if it's related, but I found that the files when they get expanded from the zip on my webhost, have the wrong case (all lowercase). When I changed the files to all have the proper case, it started to work.

    -Matt

  5. Branch
    Member
    Posted 5 years ago #

    oeconomist might have something (not that I would know). The installation in question is indeed in a subfolder: http://www.branchandroot.net/journal/.

  6. Will Norris
    Member
    Posted 5 years ago #

    any of you having trouble, try adding the following to your wp-config.php:
    define('WP_DEBUG', true);
    and see if that gives you some better error messages. You can also try looking in your apache error log or PHP's log file if you know where it is.

  7. oeconomist
    Member
    Posted 5 years ago #

    Upon activation, I now get an avalanche of diagnostics, including the following

    Fatal error: Call to undefined function: memory_get_usage() in /home/oeconomi/public_html/blogs/daniel/wp-content/plugins/openid/logic.php on line 142

    which brings me back to [Plugin: WP-OpenID] fatal error, where I explained

    With PHP versions 4.3.2 to 5.2.0, memory_get_usage() is defined if PHP was compiled with "--enable-memory-limit".

    Starting with 5.2.1, that compilation option was no longer required.

    Anyway, with WP_DEBUG defined, I couldn't log out, so I removed that, logged-out, and then re-insterted it, and attempted to log-in with my OpenID. Thence I got

    Notice: Undefined index: page in /home/oeconomi/public_html/blogs/daniel/wp-content/plugins/optimize-db/optimize-db.php on line 38

    Notice: Undefined index: pollresult in /home/oeconomi/public_html/blogs/daniel/wp-content/plugins/wp-polls/wp-polls.php on line 1274

    Notice: Undefined index: pollbooth in /home/oeconomi/public_html/blogs/daniel/wp-content/plugins/wp-polls/wp-polls.php on line 1279

    Notice: Use of undefined constant widget_aboutme_header - assumed 'widget_aboutme_header' in /home/oeconomi/public_html/blogs/daniel/wp-content/plugins/about-me-widget/aboutme.php on line 94

    Notice: Undefined index: clean_nonce in /home/oeconomi/public_html/blogs/daniel/wp-content/plugins/openid/Auth/OpenID/SQLStore.php on line 276

    Notice: Undefined index: clean_nonce in /home/oeconomi/public_html/blogs/daniel/wp-content/plugins/openid/Auth/OpenID/SQLStore.php on line 282

    Notice: Undefined index: clean_assoc in /home/oeconomi/public_html/blogs/daniel/wp-content/plugins/openid/Auth/OpenID/SQLStore.php on line 276

    Notice: Undefined index: clean_assoc in /home/oeconomi/public_html/blogs/daniel/wp-content/plugins/openid/Auth/OpenID/SQLStore.php on line 282

    Notice: Only variables should be assigned by reference in /home/oeconomi/public_html/blogs/daniel/wp-content/plugins/openid/logic.php on line 117

    Notice: Only variables should be assigned by reference in /home/oeconomi/public_html/blogs/daniel/wp-content/plugins/openid/logic.php on line 530

    Notice: Undefined property: identity_url in /home/oeconomi/public_html/blogs/daniel/wp-content/plugins/openid/logic.php on line 531

    Warning: Cannot modify header information - headers already sent by (output started at /home/oeconomi/public_html/blogs/daniel/wp-content/plugins/optimize-db/optimize-db.php:38) in /home/oeconomi/public_html/blogs/daniel/wp-includes/pluggable.php on line 770

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags