WordPress.org

Ready to get started?Download WordPress

Forums

WP-o-Matic
WP-o-Matic breaks my navigation menu every time it fetches (5 posts)

  1. kem78
    Member
    Posted 3 years ago #

    I have a custom navigation menu that is configured through Appearance Menus Subpanel. Every time WP-o-Matic fetches and publishes an article, the navigation menu is changed in random ways. Sometimes it removes pages from the menu, other times it adds pages that shouldn't even be there (such as a link to my 404 page or privacy policy). It does not appear to be an issue with my theme.

    I have tried searching the forums and Google for a solution to this bizarre problem, but have not had any luck far.

    Any suggestions on how to fix this would be greatly appreciated.

  2. missp
    Member
    Posted 3 years ago #

    Same thing happens to my menu. It removes 51 subcategories I had painstakingly added and adds other categories and pages in some random way. This is happening at least once a day if not each time it fetches. This is very frustrating and makes the plugin unusable.

  3. kem78
    Member
    Posted 3 years ago #

    Missp, I never did figure out what exactly causes this issue or how to fix it entirely. I did figure out a workaround, however. I shut off the WordPress menu system entirely and used a theme that let me manually code my own menu. It's not an ideal solution, but I haven't had any menu problems since doing this.

  4. missp
    Member
    Posted 3 years ago #

    I've done the same thing kem78. I am now using a standard dynamic menu with wp_list_categories and wp_list_pages. It's not as nice a method, but it's dynamic and it works. Thanks for your input!

    I'm afraid I have to classify this version of WP-o-Matic as being incompatible with WP 3.01 and up.

  5. missp
    Member
    Posted 3 years ago #

    Oops.. I meant to say 3.1 not 3.01.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags