WordPress.org

Ready to get started?Download WordPress

Forums

WP Minify
[resolved] Wp Minify Throwing weird errors after upgrading (14 posts)

  1. Perryb2006
    Member
    Posted 2 years ago #

    Hi,
    I upgraded WP Minify to the version released today and since then i am getting the following errors in log file.

    [04-Sep-2011 10:09:01] &m=1314867556
    [04-Sep-2011 10:09:01] &m=1313548150
    [04-Sep-2011 10:09:01] &m=1314867556
    [04-Sep-2011 10:09:01] &m=1314429130
    [04-Sep-2011 10:09:02] &m=1314867556
    [04-Sep-2011 10:09:02] &m=1314429130
    [04-Sep-2011 10:09:02] &m=1314867556
    [04-Sep-2011 10:09:02] &m=1314429130
    [04-Sep-2011 10:09:03] &m=1314867556
    [04-Sep-2011 10:09:03] &m=1314429130
    [04-Sep-2011 10:09:03] &m=1314867556
    [04-Sep-2011 10:09:03] &m=1314429130
    ........................

    the list goes on. The error log file is growing by each passing second!

    Please help!!!

    http://wordpress.org/extend/plugins/wp-minify/

  2. html-css
    Member
    Posted 2 years ago #

    I upgraded wp-minify on all my sites and facing same issue on all the sites error_log file is getting huge with these errors.

  3. html-css
    Member
    Posted 2 years ago #

    any available fix for this?

  4. Perryb2006
    Member
    Posted 2 years ago #

    No fix as of now. I have the plugin disabled and waiting for dev to answer this issue.

  5. html-css
    Member
    Posted 2 years ago #

    Yea i did the downgrade already on all my sites i love this plugin but seems like no fix will be available soon.

  6. Perryb2006
    Member
    Posted 2 years ago #

    How did you downgrade it?

  7. Vijay Padiyar
    Member
    Posted 2 years ago #

    I am also seeing similar errors in my error_log:

    [06-Sep-2011 18:25:58] &m=1310197173
    [06-Sep-2011 18:25:58] &m=1303718203
    [06-Sep-2011 18:26:09] &m=1310197173
    <snip>

    The errors are coming from the calls to WP-Minify:

    <link rel='stylesheet' href='http://site-url/wp-content/plugins/wp-minify/min/?f=wp-content/plugins/wp-recaptcha/recaptcha.css&b=beta&m=1303718203' type='text/css' media='screen' />
    
    <script type='text/javascript' src='http://site-url/wp-content/plugins/wp-minify/min/?f=wp-includes/js/l10n.js,wp-includes/js/jquery/jquery.js&b=beta&m=1309848113'></script>

    As rightly pointed out, the errors are coming after the latest upgrade. And worse, the cache directory inside plugin folder is empty, which leads me to think that the minification is not even working!

    Another issue is I am unable to get pretty URLs to work. The resultant minified CSS and JS files are just 24 bytes in size and so the website is completely messed up.

    Regards

    Vijay Padiyar

  8. html-css
    Member
    Posted 2 years ago #

    Hello Perryb2006 remove the wp-minify folder which is inside your wp-content/plugins folder thn download the most recent working version which is 1.1.6 here http://downloads.wordpress.org/plugin/wp-minify.1.1.6.zip unzip it and upload it in the wp-content/plugins using FTP thn go to the wp-minify settings page in the WordPress Admin Panel resave all the settings and it's done your version is downgraded.

  9. Perryb2006
    Member
    Posted 2 years ago #

    Thanks html-css but I already figured that out soon after asking you :)

    It working fine now. Thanks nonetheless :)

  10. kubi23
    Member
    Posted 2 years ago #

    I noticed the same behavior today. Looks like the bug comes from the following change in the last release:

    "Added last modified time to pretty URLs."

    Wait for a bugfix. The Problem does not effect the functionality of the Plugin in any way.

  11. Vijay Padiyar
    Member
    Posted 2 years ago #

    No it is not due to that change, because it is seen without pretty URLs enabled.

    I am not sure if functionality is not affected, because my cache directory inside WP-Minify plugin folder is empty with the latest version, which implies the cached files are not being generated.

    Regards

    Vijay

  12. ChowKaiDeng
    Member
    Posted 2 years ago #

    I didn't saw this post before and posted my own :

    A few days ago, my server went down after installing the Jetpack for WordPress plugin (the site was consumming about 20% CPU when it's usually 2%), I blamed Jetpack but maybe it has something to do with this... after all, the server is forced to write huge ammounts of data every few seconds to a file. I'm reinstalling Jetpack to check again the CPU ussage reports.

  13. gaspy
    Member
    Posted 2 years ago #

    Apparently the author forgot to take out a debug message.
    in wp-minify.php at line 487, take out error_log($latest_modified_string);

  14. Vijay Padiyar
    Member
    Posted 2 years ago #

    Thanks gaspy, that worked.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags