WordPress.org

Ready to get started?Download WordPress

Forums

WP Minify
[Plugin: WP-Minify] Unable to change cache expiry time (8 posts)

  1. tastingtheweb
    Member
    Posted 2 years ago #

    Hi!

    I am unable to change the cache expiry value in WP-Minify. I am using version 1.1.6 and yes, I also tried with all other plugins disabled, still no change. No matter what value I am trying with, it will not change. I have the pretty URL and the automatical Minify base options enabled.

    If you have any idea what might be causing this, feel free to share it here.

    Thanks

  2. thommy1499
    Member
    Posted 2 years ago #

    I have the same problem.

    I changed the cache time in the

    wp-minify/wp-minify.php

    function a_default_options() {
    return array(
    'cache_external' => false,
    'cache_interval' => 2592000, <- your "new" cache time

    But i am not sure, if this really works

  3. fotofashion
    Member
    Posted 2 years ago #

    Same for me. Can't change the expiration time and expired cache files don't get deleted automatically.

    Also, the 'pretty URL's' appear to be broken. They used to work in a previous release, but now the option doesn't seem to have an effect. (URL still contains a '?').

  4. gaspy
    Member
    Posted 2 years ago #

    I checked the settings file (option-generic.php) and indeed the caching time is never saved. The best way to resolve is to manually run an sql query on the database, like this:

    UPDATE wp_options SET option_value = REPLACE(option_value, '"cache_interval";i:900', '"cache_interval";i:86400') WHERE option_name='wp_minify'

  5. fotofashion
    Member
    Posted 2 years ago #

    Thanks gaspy, but even though this is a good workaround I am wondering why the developer does not respond to the problems that were posted here. If the plug-in is no longer supported, we don't need to waste time to write reports. I'd appreciate a clear statement from the developer.

  6. George Notaras
    Member
    Posted 2 years ago #

    +1 This needs to be corrected at some point. Thanks for posting your workarounds.

  7. chozian
    Member
    Posted 2 years ago #

    I am experiencing the same issue with version 1.1.8. It would be nice for this to get fixed.

  8. Jessy161616
    Member
    Posted 2 years ago #

    same by me... this sucks. please fix it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags