WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP-Members] Pick Your own Password functionality does not work (11 posts)

  1. Jared80
    Member
    Posted 2 years ago #

    According to the user guide, users should have the ability to add their own password in versions 2.7 and above:
    "NEW in 2.7: You may add a password field via the field management panel if you would like
    users to pick their own password at the time of registration."

    However, this does not appear to be working. I added a password field to the list of fields and I can see it on my registration form. But when I submit my registration with my own password field, the following behavior is observed:

    1. The password is not stored in the normal "user_pass" field of the wp_users table. Instead, the usual randomly generated by wordpress password is placed there.
    2. The password I input on my registration form is instead stored in the wp_usermeta table with a meta_key = "user_pass" and a meta_value = the password I chose on my form in CLEAR TEXT.
    3. I am unable to login successfully using the password I input on my registration form.
    4. I did not try because I don't have the email confirmation setup, but I would assume I would be able to login successfully using the randomly generated password from the wp_users table.

    In summary, it does not appear that WP Members is treating a user chosen password as a native field and therefore it is not usable by the native login process.

  2. leejsci
    Member
    Posted 2 years ago #

    Dear WP-Members

    If this function works, that will merit a sizable donation from me and others... good luck!!

    JL

  3. icedub
    Member
    Posted 2 years ago #

    I'm also unable to get the custom password feature to work. If you change the 'type' to password, I noticed that it will turn the password field from clear text to dots. This is good. However, the password is still being auto generated- it's not being set to what users input on my form. Here's a screenshot of my settings:

    http://dl.dropbox.com/u/188783/Screen%20Shot%202012-01-21%20at%207.34.14%20PM.png

  4. Chad Butler
    Member
    Posted 2 years ago #

    This function does work. I believe the problem is that I did not get it well documented prior to the version 2.7 upgrade release.

    In order for this feature to function properly, the option name MUST be 'password'.

    @Jared80 - if the password field is set up this way, it will store in the user_pass field with proper PHPass encryption. If you have something other than 'password' in the option name, the plugin will not recognize it as a password and will store it as plain text in the usermeta table with the rest of the custom fields. Thanks for taking the time to read the documentation - that's what clued me in to the fact that I had to have missed something in documenting this new feature.

    @icedub - same answer - and the screenshot helped.

    Hope that helps.

  5. Jared80
    Member
    Posted 2 years ago #

    I see. Thanks for clarifying the naming convention it looks for - "password" and not "user_pass" as I was using.

  6. Jared80
    Member
    Posted 2 years ago #

    Thinking about this some more... Was there any technical reason for choosing the "password" convention instead of "user_pass"? Seems like "user_pass" would be the ideal choice for consistency purposes, as the other native fields in WP Members do follow the wordpress naming conventions. Anyway, just a suggestion.

    Thanks for this great plugin!

  7. Chad Butler
    Member
    Posted 2 years ago #

    Yes, that would be intuitive, but "the cows are already out of the barn..." ;-)

  8. icedub
    Member
    Posted 2 years ago #

    Worked like a charm. Thanks!

  9. r_robert
    Member
    Posted 2 years ago #

    Hi guys. Password field works for registering but the user picked password is not sent in the email after account approval.

    wp_mail is working properly, if I create a user via the admin panel (Users > Add New) the password is sent to the user.

    Can you help me out with this issue? Thanks!

  10. Chad Butler
    Member
    Posted 2 years ago #

    I think this is outlined somewhere in the documentation, but it might not be very clear since the plugin development generally leads the support documentation by a bit...

    User chosen passwords are not the default, so there are some things that need to be changed in your configuration of the plugin.

    You just need to update your email content accordingly by taking the password shortcode out of the approval email (and if you want to send it to the user, add it to the initial email). It cannot be sent when they are approved since it is encrypted when stored in WP.

  11. r_robert
    Member
    Posted 2 years ago #

    I added the password to the initial email. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic