WordPress.org

Ready to get started?Download WordPress

Forums

WP-Members
[resolved] Not blocking pages (10 posts)

  1. JayBoDo
    Member
    Posted 3 years ago #

    Plugin version 2.3.2 set to unblock by default

    /members-area/ page works as expected
    /members-area/member-page-1/ shows when either logged in or logged out

    member-page-1 uses in the standard index.php template and has the custom field unblock set to true.

    No other plugins activated

    Any ideas on what could be wrong?

    Thanks!

    http://wordpress.org/extend/plugins/wp-members/

  2. Chad Butler
    Member
    Plugin Author

    Posted 3 years ago #

    You have member-page-1 set to unblock so it will show whether logged in or out. If you want it blocked when you have default set to unblock, then you need to set a custom field "block" - not "unblock"

    One note, you may be delving into unexplored territory by member-page-1 being a child page of /members-area/. Not sure if that's going to work or not.

  3. JayBoDo
    Member
    Posted 3 years ago #

    Think you need to review the wording in your FAQs:

    If you have set WP-Members to unblock by default and you want to block an individual post, use a Custom Field with the name "unblock" and set the value to "true" or "1".

    Now works as expected!

    Thanks very much

  4. Chad Butler
    Member
    Plugin Author

    Posted 3 years ago #

    Thanks for catching that and pointing it out! Actually both statements in that section are backwards and I will make the necessary corrections. Honestly, I am surprised no one has pointed that out up to now as I have not edited that part of the FAQs for awhile.

    In the meantime, if worded correctly, it supposed to be intuitive:

    if default = block then unblock = true to unblock

    -OR-

    if default = unblock, block = true to block

  5. JayBoDo
    Member
    Posted 3 years ago #

    Thought it was strange but went along for the ride :-D

    Thanks again!

  6. emarsh416
    Member
    Posted 3 years ago #

    Hi there,

    I'm also having trouble with the block setting and can't see what I might be doing wrong. I'd really appreciate some help if you have a moment.

    I've installed WP-Members plugin and have set pages and posts to be unblocked my default, and checked the option to show excerpts. Then I've set up a test page with the login widget in the sidebar. I've used the 'more' insert to divide the test content on the page. I've also installed the Simple Fields plugin and set up a field on that page called 'block' which is set to the value 'true'. However when I log out of the back end of WP and go to the page I see both the content above the 'more' insert and the stuff below it: http://www.ibforum.com/ibflive-subscribers

    Have I missed something off that I should have done? Any help much appreciated.

    Thanks,
    Elizabeth

  7. Chad Butler
    Member
    Plugin Author

    Posted 3 years ago #

    You are using Simple Fields to set the custom field? That is probably the issue... Try using a custom field via that WP Page Editor for that page.

  8. emarsh416
    Member
    Posted 3 years ago #

    Yes. Ok. The person who developed originally developed the site seems to have hidden or removed the custom fields off the edit page (!). So once I figure out how to get them back I'll try this. Thanks.

  9. Chad Butler
    Member
    Plugin Author

    Posted 3 years ago #

    In the Page/Post editor screen, look to the upper right of the screen for "Screen Options" (near the "Help" menu). Pull that down and check the box for "Custom Fields"

  10. emarsh416
    Member
    Posted 3 years ago #

    That sorted it, thank you!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags