WordPress.org

Ready to get started?Download WordPress

Forums

WP-Members
[resolved] Admin Notifications lack Name etc. (4 posts)

  1. ioflux
    Member
    Posted 3 years ago #

    First, thank you for this great plugin. It works like a charm.

    The one thing I am experiencing though is that the notifications of new registrations do not contain the first & last name (both required) or the (optional) website information of the newly registered user. It would be great if I could get this to work since the intended recipient of these notifications is not an admin & won't be able to check under Users > Users for the name of her new users.

    Your help is much appreciated.

  2. Chad Butler
    Member
    Plugin Author

    Posted 3 years ago #

    Well... there is good news and bad news.

    There is an issue with including the website/url field in the email notification process. I am planning a bug fix release to fix some minor issues, and I think I can work in a fix for this.

    That's the good news. The bad news is that there is no known issue with the name fields. These are working in the test and production systems. So I'm not sure why they wouldn't be working for you. Is the data being properly recorded otherwise? i.e. is the name field being recorded for the user and it's just not showing in the email?

    Last thing, and this is more an aside since you did not indicate it as an issue. If the user who is going to be activating users and/or otherwise working with user data and they are not an admin, you may need to work with one of the role manager plugins and add user management capabilities to the user's role. With a standard WP installation, the users below the admin do not have the ability to edit user data (which you need to activate a user with the WP-Members plugin).

  3. ioflux
    Member
    Posted 3 years ago #

    Thanks for your fast and thorough response. I am looking forward to the bug fix release.

    After I read your message I went ahead and disabled plugins one-by-one. I was able to isolate W3 Total Cache (version 0.9.1.3), specifically the Database Cache option, as the "culprit". Once disabled notifications including first & last name came through just fine.

    If you think that this is a W3TC issue, please feel free to close this thread (I am heading over to the W3TC forums...).

    Cheers!

  4. Chad Butler
    Member
    Plugin Author

    Posted 3 years ago #

    That is likely the issue. I'll mark it resolved. If you run into more problems related to this, you can shoot me a message via the contact form on my site.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic