WordPress.org

Ready to get started?Download WordPress

Forums

WP-Members
Activation Email not Being Sent (11 posts)

  1. pmagony
    Member
    Posted 1 year ago #

    Users are not receiving the welcome email when registration is moderated and user is approved by an administrator. Any ideas?

    http://wordpress.org/extend/plugins/wp-members/

  2. Chad Butler
    Member
    Plugin Author

    Posted 1 year ago #

    Are other emails being received?

  3. pmagony
    Member
    Posted 1 year ago #

    Yes, administrator receives the user sign up email, but when the administrator activates the user, the user does not receive the welcome email.

  4. Chad Butler
    Member
    Plugin Author

    Posted 1 year ago #

    Have you verified that you have content in the email dialog for moderated registration user is approved in the plugin's settings? Also, look at the content you have in that field very carefully and make sure you don't have something in there that could cause an error. Other than that, I can't think of any reason why some emails would be sent and others not.

  5. pmagony
    Member
    Posted 1 year ago #

    Hi Chad, thanks for the reply. The text that is inside of the dialog window, is the default text. Like I said, we are getting email when the user successfully registers.

    Can you point me to the table/column in the database, that handles the activation and deactivation of users?

  6. Chad Butler
    Member
    Plugin Author

    Posted 1 year ago #

    A user's activation status is determined by the meta "active" in the wp_usermeta table. When the user is activated, this is set to 1. If it is anything else, or not set (i.e. there is no "active" meta), the user is deactivated/not active.

  7. pmagony
    Member
    Posted 1 year ago #

    Chad would you be willing to take a look at my site/code? I cannot pin it down and I really need the functionality. We've got over 200 inactive users that we need to manage.

    Please advise.

    Thanks!

  8. Chad Butler
    Member
    Plugin Author

    Posted 1 year ago #

    Contact me here and we can discuss: http://rocketgeek.com/contact/

  9. jbarnabasl
    Member
    Posted 1 year ago #

    I have exactly the same problem as described by pmagony.

    The content in the email dialog for sending once moderated registration is approve is the default text. I get email when a user registers, but no email goes out to users after I've approved their registration.

    I've only just started using this plugin so don't yet have many users, but I do expect to have hundreds of users before two long. The approved users show as activated in the wp_usermeta table in the database.

    I would really value your advice.

  10. virtualist
    Member
    Posted 1 year ago #

    Hello,

    Your plugin well suits my needs and I thank you for creating it.
    However, after registration on the website, confirmation email does not arrive to the given email adress.

    I have tested wp_mail with the method you have provided on other thread and it is working perfectly.
    I have checked every singe field in plugin configuration and none is empty.
    In the emails tab under plugin settings I have changed email@yourdomain.com 'yourdomain' to my actual domain..
    I have tried with leaving email@yourdomain.com as it is but in both cases it doesn't work (mail doesn't arrive).

    I would also like to know where to add hooks code which I found on another artice. As I am not that good at coding, should I put it into wp-members.php?
    the hook code I have found is to filter the email headers that are sent through wp_mail:

    add_filter( 'wpmem_email_headers', 'my_email_headers' );

    function my_email_headers( $headers )
    {
    $headers = 'From: My Name <myname@mydomain.com>' . "\r\n";
    return $headers;
    }
    After putting this code into wp-members.php I still couldn't get email to arrive.

    I have W3TC plugin but I have been emptying cache everytime I made changes.
    I am not using moderate registration.
    Please point me to the right direction so I can get email after registration to work.

  11. Dequindre
    Member
    Posted 1 year ago #

    Having the same problem as discussed above. The "Registration is Moderated" and "Registration is Moderated, User is Approved" messages are not being sent. As mentioned above, I am getting the administrator messages fine.

    Any suggestions?

    Thanks for your assistance

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic