WordPress.org

Ready to get started?Download WordPress

Forums

WP Mail SMTP
PHPMAIL function error (4 posts)

  1. tanmayjalan
    Member
    Posted 3 years ago #

    I get this error in test message:

    Test Message Sent

    The result was:

    bool(false)

    The full debugging output is shown below:

    object(PHPMailer)#885 (44) {
    ["Priority"]=>
    int(3)
    ["CharSet"]=>
    string(5) "UTF-8"
    ["ContentType"]=>
    string(10) "text/plain"
    ["Encoding"]=>
    string(4) "8bit"
    ["ErrorInfo"]=>
    string(36) "Could not instantiate mail function."
    ["From"]=>
    string(29) "noreply@observerzparadise.com"
    ["FromName"]=>
    string(19) "Observer's Paradise"
    ["Sender"]=>
    string(0) ""
    ["Subject"]=>
    string(48) "WP Mail SMTP: Test mail to tanmayjalan@gmail.com"
    ["Body"]=>
    string(68) "This is a test email generated by the WP Mail SMTP WordPress plugin."
    ["AltBody"]=>
    string(0) ""
    ["WordWrap"]=>
    int(0)
    ["Mailer"]=>
    string(4) "mail"
    ["Sendmail"]=>
    string(18) "/usr/sbin/sendmail"
    ["PluginDir"]=>
    string(0) ""
    ["Version"]=>
    string(5) "2.0.4"
    ["ConfirmReadingTo"]=>
    string(0) ""
    ["Hostname"]=>
    string(0) ""
    ["MessageID"]=>
    string(0) ""
    ["Host"]=>
    string(9) "localhost"
    ["Port"]=>
    int(25)
    ["Helo"]=>
    string(0) ""
    ["SMTPSecure"]=>
    string(0) ""
    ["SMTPAuth"]=>
    bool(false)
    ["Username"]=>
    string(0) ""
    ["Password"]=>
    string(0) ""
    ["Timeout"]=>
    int(10)
    ["SMTPDebug"]=>
    int(2)
    ["SMTPKeepAlive"]=>
    bool(false)
    ["SingleTo"]=>
    bool(false)
    ["smtp"]=>
    NULL
    ["to"]=>
    array(1) {
    [0]=>
    array(2) {
    [0]=>
    string(21) "tanmayjalan@gmail.com"
    [1]=>
    string(0) ""
    }
    }
    ["cc"]=>
    array(0) {
    }
    ["bcc"]=>
    array(0) {
    }
    ["ReplyTo"]=>
    array(0) {
    }
    ["attachment"]=>
    array(0) {
    }
    ["CustomHeader"]=>
    array(0) {
    }
    ["message_type"]=>
    string(5) "plain"
    ["boundary"]=>
    array(2) {
    [1]=>
    string(35) "b1_587df790414c8be5247a857dc6da6502"
    [2]=>
    string(35) "b2_587df790414c8be5247a857dc6da6502"
    }
    ["error_count"]=>
    int(1)
    ["LE"]=>
    string(1) "
    "
    ["sign_cert_file"]=>
    string(0) ""
    ["sign_key_file"]=>
    string(0) ""
    ["sign_key_pass"]=>
    string(0) ""
    }

    http://wordpress.org/extend/plugins/wp-mail-smtp/

  2. dude
    Member
    Posted 3 years ago #

    try switching the SMTP Port to 26

    in the settings

  3. dude
    Member
    Posted 3 years ago #

    and switch mailer to: Send all WordPress emails via SMTP.

  4. dude
    Member
    Posted 3 years ago #

    also you have a 'noreply@observerzparadise.com'
    use the 'Mail From' plugin to change the 'norelpy'

    you must create an email address in cpanel to use instead of 'noreply'

    for example you@yourdomain.com

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic