WordPress.org

Ready to get started?Download WordPress

Forums

Wp-ImageZoom
parsererror (20 posts)

  1. iskradi
    Member
    Posted 1 year ago #

    Hi,
    I try to use wp image_zoom, but I receive this message:

    XMLHttpRequest: [object XMLHttpRequest]
    textStatus:parsererror
    errorThrown: Invalid JSON: <div style="display:none"><b></b>

    </font>

    http://mapmediabg.com/wp-content/plugins/wp-imagezoom/zoom.php?id=dnswl

    What can be the reason?
    iskradi

    http://wordpress.org/extend/plugins/wp-imagezoom/

  2. aueda
    Member
    Plugin Author

    Posted 1 year ago #

    I found a reason.
    When you insert an image into an article, the selection of the 'Link To' combobox must be 'Media File' instead of 'Attachment page' etc.

  3. yogeeta
    Member
    Posted 1 year ago #

    Hi Aueda,

    I am getting the same error. I did not understand what you mean by "the selection of the 'Link To' combobox must be 'Media File' instead of 'Attachment page'"

    Could you please explain how to use this plug in.

    Thank you.

  4. aueda
    Member
    Plugin Author

    Posted 1 year ago #

    I'm sorry. There is 'Link to' combobox in the Insert Media screen of WordPress 3.5 beta3. In the current version of WordPress there is 'Link URL' textbox in the "Add Media" screen. When you insert an image between [izoom] and [/izoom] you needed to enter the URL of the original image (http://****.jpg) in the Link URL textbox, instead of attachment post URL (http://****/?attachment_id=???) etc.
    But yesterday I updated the plugin and now the attachment URL is also OK.
    So please try the latest plugin(Ver1.0.6).

  5. yogeeta
    Member
    Posted 1 year ago #

    Hi Aueda,

    This is how my code looks like:

    [izoom]<a href="http://remotereality.in/ldwordpress/wp-content/uploads/2012/10/Full-Test.jpg"><img src="http://remotereality.in/ldwordpress/wp-content/uploads/2012/10/Thumbnail-Test.jpg" alt="" /></a>[/izoom]

    I have not attached an image. I have pasted the image location in the code above and I am still getting this error. Here is the page on which I am trying to implement this plug-in:

    http://remotereality.in/ldwordpress/?page_id=721

    Please let me know what could be the problem.

    Thank you.

  6. yogeeta
    Member
    Posted 1 year ago #


  7. aueda
    Member
    Plugin Author

    Posted 1 year ago #

    I tried the plugin in my shared hosting account and I experienced the similar problem. I'll fix it.

  8. yogeeta
    Member
    Posted 1 year ago #

    Thank you! Please do inform me once it is fixed. It is an amazing plug-in and is perfect for my website!

  9. aueda
    Member
    Plugin Author

    Posted 1 year ago #

    If "allow_url_fopen" of the PHP setting is not enabled, please ask your server administrator to change the setting.
    If that is not possible, modify your post like following:

    (before)
    [izoom]<img src="http://???.com/wp-content/upload/???-100x100.jpg">[/izoom]
    (after)
    [izoom]<img src="http://???.com/wp-content/upload/???-100x100.jpg">[/izoom]

    How is the result?

  10. yogeeta
    Member
    Posted 1 year ago #

    Hi,

    I am still not able to get the plug-in to work.

    I don't really understand what changes you have asked me to make in the code.

    Please explain.

    Thank you.

  11. aueda
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry. I made a mistake.

    (before)
    [izoom]< a href="http://???.com/wp-content/upload/???.jpg"><img src="http://???.com/wp-content/upload/???-100x100.jpg">< /a>[/izoom]
    (after)
    [izoom]< a href="/wp-content/upload/???.jpg"><img src="http://???.com/wp-content/upload/???-100x100.jpg">< /a>[/izoom]

    delete http:// and server name in the a-tag.
    (I inserted a whitespace before "a" because writing a-tag in the post cause a problem.)

  12. yogeeta
    Member
    Posted 1 year ago #

    Hi,

    I am still unable get it to work after removing http:// and the server name!

    What could be the issue?

    Thank you.

  13. yogeeta
    Member
    Posted 1 year ago #

    This is the code:

    [izoom]<img src="http://remotereality.in/ldwordpress/wp-content/uploads/2012/10/Solutions-Industry-3.jpg" alt="" />[/izoom]

    And this is the page where the above code is:
    http://remotereality.in/ldwordpress/?page_id=740

    It does not show an error message but it does not load the image in the pop up window.

  14. aueda
    Member
    Plugin Author

    Posted 1 year ago #

    I cannot see your code correctly.
    (writing a-tag in the post in this forum cause a problem.)

    I think the following code is correct:
    [izoom]< a href="/ldwordpress/wp-content/uploads/2012/10/Solutions-Industry-3.jpg"><img src="http://remotereality.in/ldwordpress/wp-content/uploads/2012/10/Solutions-Industry-3.jpg">< /a>[/izoom]

    ('/ldwordpress' is missing in your code?)

  15. yogeeta
    Member
    Posted 1 year ago #

    Hi Aueda,

    Could you please give me your email address so that I can send you my code. I am still unable to get the plug in to work.

    Thank you.

  16. aueda
    Member
    Plugin Author

    Posted 1 year ago #

    Please contact me by using the contact form.
    http://tempspace.net/plugins/?page_id=301

  17. wpjm
    Member
    Posted 1 year ago #

    hi

    i like the plugin but i have the same problem after click on image it show a new page with all buttons for zoom but no image, it say "indefined"

    where is the problem?

    this is the code in the page
    [izoom]<img src="http://working-site.net23.net/wp-content/uploads/2012/12/1tumb.jpg">[/izoom]

    i just donload the pugin today! apreciate help to make it work!

  18. wpjm
    Member
    Posted 1 year ago #

  19. wpjm
    Member
    Posted 1 year ago #

    sorry for 3 post but it dint show all code

    izoom as usual

    <img src="http://working-site.net23.net/wp-content/uploads/2012/12/1tumb.jpg">

  20. aueda
    Member
    Plugin Author

    Posted 1 year ago #

    Hi wpjm,

    I tried the server you are using (because it was available for free). I noticed that the server does not return the correct value of $_SERVER['DOCUMENT_ROOT']. So inserting the following line in the second line of div_img.php will solve the problem:

    $_SERVER['DOCUMENT_ROOT'] = "/home/a1234567/public_html";

    (Replace 'a1234567' with your ID.)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.