WordPress.org

Ready to get started?Download WordPress

Forums

WP Flow Plus
[Plugin: WP-ImageFlow2] Only 4 images showing (14 posts)

  1. lolatech
    Member
    Posted 2 years ago #

    I LOVE this plug in, but am running into a big snag.
    No matter how many, or what pictures I add to the gallery, only 4 pictures will show. I have tried removing and reinstalling, as well as deactivating the other plug in that I have running, but nothing seems to work. Here is a link to the page: http://lolatech.net/?page_id=4
    Can someone please point me in the right direction? Thanks

    http://wordpress.org/extend/plugins/wp-imageflow2/

  2. rexhaugen
    Member
    Posted 2 years ago #

    Are you still having encountering this problem?

  3. lolatech
    Member
    Posted 2 years ago #

    yes I am - any advice?

  4. rexhaugen
    Member
    Posted 2 years ago #

    How many images are attached to the page? It should show you in the media library or on the page click the "add image" icon and select gallery. The plugin looks to the attached images to determine what should be shown.

  5. lolatech
    Member
    Posted 2 years ago #

    Thank you for the suggestion, but there are currently 7 images attached to the page, but only 4 will show.

  6. rexhaugen
    Member
    Posted 2 years ago #

    A good plugin to manage what images are attached to which posts, check out File Gallery.

  7. rexhaugen
    Member
    Posted 2 years ago #

    In your WPImageFlow settings, is the directory option set?
    Also, have you made any changed to the JS or PHP for the plugin?

  8. rexhaugen
    Member
    Posted 2 years ago #

    Also, do you have the most up to date version of WP-ImageFlow2? It looks like it may be an older version according to the JS file.

  9. rexhaugen
    Member
    Posted 2 years ago #

    Does your site use the Minimatica theme? I just attempted to test a new WP-ImageFlow2 implementation on another of my sites that is using Minimatica and I am now encountering the same issue. I wonder if there could be a compatibility problem, which might make sense why it only displays 4 as that is the same number of images that Minimatica displays by default.

  10. lolatech
    Member
    Posted 2 years ago #

    ahhh! that could be it! Yes, I am using the minimatica theme, and LOVE it. If I can't figure it out, I will just find another plug in, because the theme is so great.

  11. rexhaugen
    Member
    Posted 2 years ago #

    I'm using Minimatica on my main homepage and I tested the ImageFlow here. I know that Minimatica handles attached images in a slider, so that could be causing the problem.

  12. rexhaugen
    Member
    Posted 2 years ago #

    In functions.php of the Minimatica theme, there is an option $query->set( 'posts_per_page', '4' );. That determines how many images it shows per slider page and that is also where the problem is originating from. If you increase that number, it will change how your slider appears, but it will also increase the number of images shown in the imageflow.

  13. lolatech
    Member
    Posted 2 years ago #

    you are a genius! Thanks!
    What I did for the homepage slide was set which category of posts were to be displayed, and made a category called 'homepage'.

    Thanks again!

  14. rexhaugen
    Member
    Posted 2 years ago #

    That's exactly what I did as well. I disabled paging so it would display 8 specific frontpage posts. Because I disabled paging, I never changed the posts_per_page value.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic