WordPress.org

Ready to get started?Download WordPress

Forums

WP htaccess Control
no longer properly redirects to www (6 posts)

  1. 8bitkid
    Member
    Posted 3 years ago #

    even when enabling the canonical url option, WordPress no longer forces www. when this plugin is active.

  2. Antonio
    Member
    Posted 3 years ago #

    What the canonical url option does is adding or removing the www part from the WordPress URL settings on options-general.php.
    I've just given it a try and one of the settings is not changing, I'll be fixing this.
    Thank you for pointing it out.

  3. Antonio
    Member
    Posted 3 years ago #

    This should be fixed on version 2.1.2.

  4. 8bitkid
    Member
    Posted 3 years ago #

    i just upgraded and tried again, but it is still doing the behavior where a blog previously setup to correct redirect any non-www to www no longer does so. instead, if the user omits www, it stays that way.

  5. Antonio
    Member
    Posted 3 years ago #

    Have you re-submitted your settings again since the upgrade?
    Under Settings>General, do you have WordPress address and Site address with or without the www part at this point?

  6. 8bitkid
    Member
    Posted 3 years ago #

    the settings for both the WP address and site address both contain "www.". i have the plugin activated currently, and ran "reset all rules" and saved. however, i am still experiencing the issue. fyi, my wordpress blog files directory is not at the site root. so i have http://www.example.com as the site address and http://www.example.com/blog/ for the WordPress address.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic