WordPress.org

Ready to get started?Download WordPress

Forums

WP htaccess Control
[resolved] I can't access anything (5 posts)

  1. dmolnar@titanyork.com
    Member
    Posted 2 years ago #

    I tried changing the author base, I just wrote author in the box, hit update and now I cannot access the control panel or any blog pages at all.

    I'm not sure how do I fix this? I tried renaming the plugins folder but it didn't do anything...

    http://wordpress.org/extend/plugins/wp-htaccess-control/

  2. dmolnar@titanyork.com
    Member
    Posted 2 years ago #

    What I wanted to do was change it so that the author's user name is not part of the permalink for author pages... is it possible to make it their display name instead of user name?

  3. dmolnar@titanyork.com
    Member
    Posted 2 years ago #

    oh ok, I managed to get back in by deleting the htaccess file in the root directory...
    Thanks, don't know why this happened... I did a lot of the "recommended settings" as well, but they didn't seem to create an error as I was still able to update the "author base"

  4. dmolnar@titanyork.com
    Member
    Posted 2 years ago #

    Still, none of my blog links work now even after disabling...

    Update: The permalinks for the blog posts and pages were modified in the default settings, I updated that setting and it all the old links work now I think.

  5. Antonio
    Member
    Posted 2 years ago #

    Hi dmolnar,

    For this plugin to work, the permalink settings must not be "default", ie.: "?p=123" (otherwise WP won't even create a htaccess file).

    When everything goes wrong you should just delete the *.htaccess file generated at the root of your blog, and resubmit your WP permalink settings, on wp-admin/options-permalink.php. If this is not enough I guess you could delete this plugin's folder.

    I'd also suggest you to try the htaccess suggestions slowly, ideally one by one: there's nothing wrong with them but as server configurations vary, some of them may not work on your particular environment.

    Using the display name instead of the username on permalinks, could be done (although, at the moment, this plugin can't), however this represents an issue: unlike usernames, display names are not url friendly by nature.

    I'm not sure if any of this helps but you seem to have recovered from the trouble in the end...

    Antonio

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic