WordPress.org

Ready to get started?Download WordPress

Forums

wp-forecast
[resolved] Translation language (7 posts)

  1. nkar72
    Member
    Posted 1 year ago #

    Since now i used wp-forecast with this trick:
    i edited "en_US.po" and translated the strings i wanted in greek language.

    After updating to lated version this trick stopped working. So i did the same with the file "wp-forecast_en_US-en_US.po". It didn't worked.

    Then i tried this. From file "wp-forecast.pot" i created a new .po file named "wp-forecast_el_EL-el_EL.po" which i transferred to directory "/lang" (of course and the "wp-forecast_el_EL-el_EL.mo" file). Also i edited "wp-forecast-admin.php" and changed a line for "german" to this:

    <option value="el_EL" <?php if ($av['wpf_language']=="el_EL") echo "selected=\"selected\""?>>greek</option>

    From admin panel i changed settings for language to greek but the widget on my site it still showing english language.

    Do you have any ideas that could help me?

    http://wordpress.org/extend/plugins/wp-forecast/

  2. nkar72
    Member
    Posted 1 year ago #

    i don' know if this can help, but what i noticed is that the widget shows strings from source text of the .po file (both in english or greek language settings)

    [ Please do not bump, that's not permitted here. ]

  3. nkar72
    Member
    Posted 1 year ago #

    I tried and changed wordpress settings for language to "" (deafault) and this time the widget worked. If i change it back to "el" it still not working.

  4. nkar72
    Member
    Posted 1 year ago #

    i am trying it in two different sites. In the one that i use WPML plugin there is the problem. In the other one it works fine. So i asume that there is a conflict with wp-forecast and WPML plugins.

  5. nkar72
    Member
    Posted 1 year ago #

    When i turn back version from 4.1 to 4.0 the widget works fine. So i believe that is something that has to do with the change at the .po files
    Version 4.1: changed translation loading from load_textdomain to load_plugin_textdomain

  6. tuxlog
    Member
    Plugin Author

    Posted 1 year ago #

    Hello nkar,

    well, to keep it simple, send me the translation and I will integrate it in wp-forecast during the next days.

    Send it to webmaster at tuxlog dot de.

    Regards, Hans

  7. nkar72
    Member
    Posted 1 year ago #

    The problem solved after installing the latest 4.2 version.

    Also i sent you the translation files.

    thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.