WordPress.org

Ready to get started?Download WordPress

Forums

WP-Footnotes
[WP Footnotes 3.3] array key error prevents save WP 3.0 (12 posts)

  1. cburell
    Member
    Posted 3 years ago #

    Using WP 3.0 and WP Footnotes 3.3, getting this message when trying to save or update a post:

    Warning: array_key_exists() [function.array-key-exists]: The first argument should be either a string or an integer in .../html/wp-content/plugins/wp-footnotes/footnotes.php  on line 167
    
    Warning: Cannot modify header information - headers already sent by (output started at .../wp-content/plugins/wp-footnotes/footnotes.php:167) in /nfs/c01/h09/mnt/32929/domains/beyond-school.org/html/wp-includes/pluggable.php on line 890
  2. Ivaylo Draganov
    Member
    Posted 3 years ago #

    I confirm the same error. Anybody know if this plugin is still in development?

  3. drzax
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Folks,

    Yes this is still under development. Working on an update now, however can't replicate this problem. I'll keep looking into it, but if you've got any more information about the error that would be great.

  4. tizz
    Member
    Posted 3 years ago #

    Hi,
    The new version doesn't work well with WP 2.9
    In the pop-up (in the text) entities are seen, while notes at the bottom of the text looks right.

  5. Tommy David
    Member
    Posted 3 years ago #

    I have the same problem with WordPress 3.0.1 and WP Footnotes 4.0...

  6. fahirsch
    Member
    Posted 3 years ago #

    I get the same error on saving. Now with version 4 and WP 3.0.
    But on viewing the post the footnote appears ok.

  7. drzax
    Member
    Plugin Author

    Posted 3 years ago #

    Hi All. The best place to report bugs is over at the WP Plugins Trac system. I've created a ticket for this error. Please add any further notes over there.

    http://plugins.trac.wordpress.org/ticket/1185

    Cheers.

  8. fahirsch
    Member
    Posted 3 years ago #

    Testing version 4.1 makes it worse. I get additional Warnings

    Warning: htmlentities() expects at most 3 parameters, 4 given in /var/www/vhosts/fiscaldemesa.com.ar/httpdocs/wp-content/plugins/wp-footnotes/footnotes.php on line 217

    Going back to version 4 I tried disabling plugins to see if there was a conflict with another plugin. I discovered, that in my case, that disabling Google XML Sitemaps 3.2.4 "solved" the problem.

  9. drzax
    Member
    Plugin Author

    Posted 3 years ago #

    @fahirsch I've released 4.2 which should address the problem. It looks as though you're running WordPress on a server with PHP < 5.2.

    It is probably worth nothing that WP itself will soon drop support for PHP versions below 5.2 - might be worth contacting your host for an upgrade.

    http://wordpress.org/news/2010/07/eol-for-php4-and-mysql4/

  10. tizz
    Member
    Posted 3 years ago #

    Hi, I don't understand what you said about what to do with the "entities bug".
    Now I've updated to WP 3.0.1, tried again 4.2 plugin version, but the bug it's the same: in the pop-up window entities are seen.
    Are you working at a new version?
    Thanks

  11. Bettega
    Member
    Posted 3 years ago #

    I`m getting this error with WP 3.1.1 and Footnotes version 4.2

  12. tizz
    Member
    Posted 3 years ago #

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic