WordPress.org

Ready to get started?Download WordPress

Forums

WP-Filebase Download Manager
[resolved] Sync filebase with files over 2GB (8 posts)

  1. funky_buddah
    Member
    Posted 1 year ago #

    it seems that the sync function doesn't work for files over 2GB.
    does somebody know where I can modify this limit?

    has anybody else encountered this problem?

    http://wordpress.org/extend/plugins/wp-filebase/

  2. david-SBM
    Member
    Posted 1 year ago #

    Sounds like an issue with your upload limit size in your php.ini file. Depending on your host, you may be able to change the value upload_max_filesize in the php.ini file to reflect a higher limit than 2MB. That file should be in the directory where your php install is.

    If that doesn't work, there are some other methods to try including altering your .htaccess file. Give this a read:
    http://wordpress.org/support/topic/increasing-max-filesize?replies=8

  3. Fabian
    Member
    Plugin Author

    Posted 1 year ago #

    Any error messages?
    Try disabling ID3 tag detection in WP-Filebase settings

  4. funky_buddah
    Member
    Posted 1 year ago #

    @fabi: the ID3 detection and automatic thumbnail detection are disabled. No error message.

    @david: the issue is about 2GB, not 2MB, man :) The links is interesting, though, thanks.

    Here's the problem's flow: I upload a file larger than 2GB through FTP -> syncfilebase -> no new file found.

  5. funky_buddah
    Member
    Posted 1 year ago #

    hello fabi,

    Do you use curl for getting the filesize?
    because it seems that that 2 GB limit is a known curl "feature" :)
    http://curl.haxx.se/mail/lib-2003-08/0145.html

  6. funky_buddah
    Member
    Posted 1 year ago #

    btw, I'm on a 32-bit linux system and it seems that the 2GB file size limitation is built deep into the linux kernel.

    should I upgrade to a 64-bit linux distro?

  7. Fabian
    Member
    Plugin Author

    Posted 1 year ago #

    WP-Filebase uses WP_Http to retrieve HTTP headers and PHP's HTTP stream wrapper to load files, so there shouldn't be any file size limit, except the one in linux.
    Upgrading your distro should help.

  8. funky_buddah
    Member
    Posted 1 year ago #

    Indeed it helped. On a 64-bit system, the detection works perfect.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.