WordPress.org

Ready to get started?Download WordPress

Forums

WP-Filebase Download Manager
[resolved] Category Permissions not working (9 posts)

  1. Imaje
    Member
    Posted 2 years ago #

    Hello again,

    I'm using Version 0.2.9.6 of this plugin.
    I have noticed a problem that I believe was reported in the previous version.

    Basically, when I upload a new file, I select which category I want the file to be in, however the file does not inherit the categories permissions, I therefore need to select *for members only* and the users manually everytime I want to insert a new file into a page (in my case, a page)

    Am I missing something here? have a I missed another setting? or is this a bug?

    http://wordpress.org/extend/plugins/wp-filebase/

  2. Fabian
    Member
    Plugin Author

    Posted 2 years ago #

    Fixed in 0.2.9.7

  3. Tevya
    Member
    Posted 2 years ago #

    I've updated to the latest version 0.2.9.9 and am still having this same problem. I've noticed that the "Apply permission to all child files" checkbox does not stay checked under the category settings. It would be super nice to not have to set the permissions on each file.

  4. Fabian
    Member
    Plugin Author

    Posted 2 years ago #

    Thats not an issue. When checking "Apply permission to all child files" permissions are applied only once. New files will automatically inherit permissions despite this checkbox has ever been used.

    Actually it would be less confusing to make a button for this..

  5. Tevya
    Member
    Posted 2 years ago #

    Okay, but it still doesn't work. It shouldn't display the links to users who are not logged-in, but it does. All files are in one category, with it set to display for any level user. But non-logged in viewers can see the files as well. It's not working.

  6. Fabian
    Member
    Plugin Author

    Posted 2 years ago #

    Check WP-Filebase Security Settings and file permissions in WP-Filebase -> Files in WP-Admin.
    Can they download the files?

  7. Tevya
    Member
    Posted 2 years ago #

    So it now appears to be working on all but one file. It may have been WP Supercache had them still cached for logged-out users. I just can't figure out why this one file doesn't work....

  8. siraper
    Member
    Posted 2 years ago #

    I had the same problem, but I think I've resolved it...

    your plugin creates the category directory with one user called "apache" and I can't upload files with my site-user...

    I've solved it deleting the category directory and creating it again with my user, so I can upload files now without problems...

    (Anyone has a more elegant solution?)

    I'm using Apache on CentOS4 ... I hope it helps anyone, because I was blocked during one week!!!

    Anyway, GREAT PLUGIN fabifott!!!

    Jorge Rivera, Madrid.

  9. siraper
    Member
    Posted 2 years ago #

    Hi everyone...

    I discover my problem...

    in my dedicated server, I have PLESK 9.5 and it manages the domains with a default cponfiguration for PHP... it enables a called "secure mode for PHP" and it enables an user owner system who was fatal to wp filebase...

    just disable the "secure mode PHP" and everything is OK!

    I hope it helps anyone... I lost 2 weeks... :D

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic