WordPress.org

Ready to get started?Download WordPress

Forums

WP Feedback & Survey Manager
[resolved] Submit button not working in chrome, but works in ie8 (6 posts)

  1. Alan_eyetee
    Member
    Posted 1 year ago #

    Great survey tool, however I can not make the 'submit' button or next / previous button do anything in the 'Chrome' browser. The same survey form works a treat in ie8.
    http://www.mantlesgroup.co.uk/buyers-survey

    http://wordpress.org/extend/plugins/wp-feedback-survey-manager/

  2. Alan_eyetee
    Member
    Posted 1 year ago #

    Also when looking at the same form with my iphone, or ie9 I have the same problem, the 'previous' and 'submit' are greyed out and the 'next' button looks active, but nothing actually happens.

  3. Swashata Ghosh
    Member
    Plugin Author

    Posted 1 year ago #

    Hello,
    It seems there is some jQuery conflict in your site. It is hard for me to say why it is exactly. What you need to do is, disable your other plugins one by one until the problem solves and then report here about the plugin which caused this problem. If the problem persists even after disabling all plugins, then the issue should be related to your theme.

  4. Alan_eyetee
    Member
    Posted 1 year ago #

    Hello,
    I have tried it with 2 sites that I run with themes and it fails on both. This is a real shame as it looks such a great survey tool. Sadly I will have to find an alternative.
    It would be great if you manages to work around the conflicting jQuery problems.

  5. Swashata Ghosh
    Member
    Plugin Author

    Posted 1 year ago #

    Hello,
    I looked deep into your problem, and it seems this file: http://www.mantlesgroup.co.uk/wp-content/themes/wowway/js/plugins.min.js is causing all the trouble. The fact is that jQuery.tabs is defined twice and therefore breaking the script.

    For now I'd suggest removing that file from your theme or simply edit form-class.php and remove the jquery.ui.tabs enqueue.

    In future I will add more options to deal with such problems.

  6. Dani Weymouth
    Member
    Posted 1 year ago #

    Similar issue here. I tried removing that file mentioned above but it only screws up the form more. I'm running out of time. @Swashata, any ideas yet?

    Mine can be seen at: http://thesmallbusinessfactory.com/adja-survey/.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic