WordPress.org

Ready to get started?Download WordPress

Forums

WP-FB-AutoConnect
[resolved] Simplemodal login conflict (4 posts)

  1. Jonas
    Member
    Posted 1 year ago #

    Hi,

    I installed the simplemodal login plugin.

    I would like the login with facebook option to show in the form there is some sort of conflict. My guess that the script loads to quickly

    Any advice on how to make this worK?

    Jonas

    http://wordpress.org/extend/plugins/wp-fb-autoconnect/

  2. justin_k
    Member
    Plugin Author

    Posted 1 year ago #

    You can try to alter jfb_output_facebook_btn() to just output the tag directly, rather than using javascript:document.write().

    Also, please see FAQ36.

  3. falc0nit3
    Member
    Posted 12 months ago #

    Were you able to get this sorted? I'd like to be able to add the facebook button onto a modal. Could you please elaborate a bit more Justin?

    I did try to output the tags directly but that doesn't do anything and the button doesn't show up. Any help is greatly appreciated. Thanks!

  4. falc0nit3
    Member
    Posted 12 months ago #

    I got it to work by modifying jfb_output_facebook_btn() as Justin mentioned above:

    <span class="fbLoginButton">
    <?php echo '<fb:login-button scope="'. $scope . '" v="2" size="small" onlogin="'. $jfb_js_callbackfunc . '()">'. apply_filters("wpfb_button_text", "Login with Facebook") . '</fb:login-button>'; ?>
    </span>

    This should output the facebook button on any modal (lightbox/simplemodal etc)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.