WordPress.org

Ready to get started?Download WordPress

Forums

WP Facebook Open Graph protocol
[resolved] Error Parsing URL (11 posts)

  1. janolima
    Member
    Posted 2 years ago #

    It seems like facebook made changes or something is happen.

    Few days ago everything was running fine but I recently see this error: Error Parsing URL: Error parsing input URL, no data was scraped.

    The only change I made is upgrading WP from 3.3.1 to 3.3.2.

    Any ideas?

    Thanks a lot.

    Alejandro

    http://wordpress.org/extend/plugins/wp-facebook-open-graph-protocol/

  2. Andrew Ryno
    Member
    Plugin Author

    Posted 2 years ago #

    Do you have a URL so I can take a look? Could be a lot of things.

    Thanks,
    Andrew

  3. janolima
    Member
    Posted 2 years ago #

    Yes, here:

    http://goo.gl/pGGaw

  4. Andrew Ryno
    Member
    Plugin Author

    Posted 2 years ago #

  5. janolima
    Member
    Posted 2 years ago #

    Yes, I can see now.

    And what about the shown warning?:

    The parser's result for this metadata did not match the input metadata. Likely, this was caused by the data being ordered in an unexpected way, multiple values being given for a property only expecting a single value, or property values for a given property being mismatched. Here are the input property =>content pairs that were not seen in the parsed result: 'og:url => , og:locale:locale => '

  6. majonez
    Member
    Posted 2 years ago #

    Hi,

    I had this problem too...

    I edited FB OGP plugin, and add hu_hu locale instead of hu_HU, so my line is:

    echo '<meta property="og:locale" content="hu_hu">' . "\n";

    The problem in FB debug disappeared.

    Andrew

  7. janolima
    Member
    Posted 2 years ago #

    Thanks for share.

    Yes the og:locale debug disappeared but og:url debug persists.

    Regards.

  8. adityaaguptaa
    Member
    Posted 2 years ago #

    My plugin at present shows -

    // do locale
    echo '<meta property="og:locale" content="' . esc_attr( get_locale() ) . '">' . "\n";
    echo "<!-- // end wpfbogp -->\n";

    Should i Change this to -

    // do locale
    echo '<meta property="og:locale" content="hu_hu">' . esc_attr( get_locale() ) . '">' . "\n";
    echo "<!-- // end wpfbogp -->\n";

  9. Andrew Ryno
    Member
    Plugin Author

    Posted 2 years ago #

    adityaaguptaa: I would recommend against editing the plugin directly, but you want, you can do this:

    echo '<meta property="og:locale" content="hu_hu">' . "\n";

    I'll make sure this is fixed in the next version. I'm also not sure what's wrong with Facebook when it has og:locale:locale but I'll be looking into that as well.

  10. adityaaguptaa
    Member
    Posted 2 years ago #

    Cool. I'll wait for the next version to come out. And hope that is soon enough. Thanks!

  11. Chuck Reynolds
    Member
    Plugin Author

    Posted 2 years ago #

    Pushed an update (2.0.3) that should nuke that Facebook parser mismatched metadata warning.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic