WordPress.org

Ready to get started?Download WordPress

Forums

WP Evernote Site Memory
Nothing happens when I click on evernote SM image (7 posts)

  1. djinn73
    Member
    Posted 3 years ago #

    Hi Jonathan,

    I am testing this on my blog at http://interculturalzone.lokahi-interactive.com.

    I installed the plug in, made sure the call wp_footer was present, and nothing happens when I click on the image.

    Relatedly, it seems installing the plug in is slowing down the site, at least when I am working on the back office. Coincidence?

    Thanks for your help!

    http://wordpress.org/extend/plugins/wp-evernote-site-memory/

  2. Jonathan Desrosiers
    Member
    Plugin Author

    Posted 3 years ago #

    Thanks for moving this to the WordPress forums :)

    First to address the slowing down of the website. The plugin itself is only 800kb, and only adds a few hooks and actions to WordPress.
    Additionally, the Evernote site memory feature is designed to NOT slow down your website because the needed Javascript for the clip feature is not loaded until the last possible section of your website. So your page should load prior to Evernote's script loading, pushing any delay to after your content is output.

    If you are experiencing issues with performance, you can try using the minified version of the Javascript, which is a setting at the bottom of the WP Evernote Site Memory settings page.

    Now as for the issue of your site's clip buttons not working, here are some steps I would take to diagnose the issue.

    1. Please disable all plugins that you are running currently, leaving only WP Evernote Site Memory activated. Test the clipping button to see if it works. If it does, we know it is clashing with another plugin. Activate plugins one by one, and test the button after each one. When it stops working, we know that it is the plugin you last activated, and we can look at why that plugin might be breaking it. Deactivate that plugin, and continue to activate plugins one by one and see if another plugin breaks the button.
    2. If it does not work with all other plugins disabled, then it is an issue with your theme's code. Validate your code here and try to correct any errors you find.

    Hope this helps, and let me know how you make out with this, especially step one, and then we can decide what to try next!

  3. djinn73
    Member
    Posted 3 years ago #

    That's a good shopping list of things to check!
    I'll have to do that when it is not inconvenient for the blog to be somewhat down and I have a chunk of time.
    For the time being, I'll deactivate this plug-in just in case its bug would annoy a visitor.
    I'll come back when I have run the tests.

  4. Jonathan Desrosiers
    Member
    Plugin Author

    Posted 3 years ago #

    Ok, very curious to hear how it works out! Keep in mind as well, the more plugins you run, the more it will tax your server, and slow load time. If you have any plugins that are no longer useful, weed them out and leave them inactive.

  5. Jonathan Desrosiers
    Member
    Plugin Author

    Posted 3 years ago #

    Did you have any luck when testing this? Was wondering how you made out.

  6. djinn73
    Member
    Posted 3 years ago #

    Thanks for your message desrosj. I've been swamped and haven't had the time to go through all the steps you listed. Moreover, in thinking about it, should it be an incompatibility with one of my plug-ins, I'd be in a double bind: the Evernote one is a nice bell and whistle, but the plug-ins I use I would not want to remove. I still plan to test when I have a chunk of time to do so!

  7. Jonathan Desrosiers
    Member
    Plugin Author

    Posted 3 years ago #

    djinn73, we are releasing a new version of the plugin this week. Check it out, maybe it will solve your problems. Worth a shot!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic