WordPress.org

Ready to get started?Download WordPress

Forums

WP Evernote Site Memory
[resolved] Add a CSS class or id to the clipping button (5 posts)

  1. ewall
    Member
    Posted 3 years ago #

    I've just installed the WP Evernote Site Memory plugin, and I like what I see so far.

    However, in my current theme the clip button is showing up with an ugly border around it. I could tweak my CSS to disable the border for that element, but since the Site Memory anchor & image do not have a CSS class or id, it's pretty hard to write an appropriate selector...

    So I guess my request is that, in a future version, could you assign a CSS class or id for the clip button so we could style it appropriately? Thanks!

    http://wordpress.org/extend/plugins/wp-evernote-site-memory/

  2. ClaytonJames
    Member
    Posted 3 years ago #

    Did you get a chance to try modifying and adding any of these classes to the bottom of your style sheet?

    WP Evernote Site Memory FAQ

    "Can I style the button?

    The button itself is an image. Therefore certain aspects of it can not be changed. However the Site Memory button is composed of three HTML elements that will allow you to further customize the button with css styles. The 3 components are a <div>, an <a>, and an <img>. They are assigned the CSS classes evernoteSiteMemory, evernoteSiteMemoryLink, and evernoteSiteMemoryButton respectively."

  3. Jonathan Desrosiers
    Member
    Plugin Author

    Posted 3 years ago #

    Hi ewall,
    I just looked and you are right about the classes missing. I did intend to have this as you can see ClaytonJames quoted the FAQ section, however it is in the dev version. We are going to be working on an updated version over the next week, and hope to have that out soon!

  4. Jonathan Desrosiers
    Member
    Plugin Author

    Posted 3 years ago #

    Releasing a new version this week. Please check it out. CSS Selectors are included to help fix your issue.

  5. ewall
    Member
    Posted 3 years ago #

    Excellent... I saw that some of the groundwork had been laid for it, but the classes aren't applied to the image in version 1.0.4. I'll pick up the new one as soon as I see it--thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic