WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Wp-e-commerce] Pagination for products not working (36 posts)

  1. Warwick Booth
    Member
    Posted 4 years ago #

    I am running 3.7 of the wp-ecommerce plugin and my pagination isnt working on the products page.

    http://www.originroasting.feedmydemo.co.za/the-coffee/products-page/

    Im not sure what to do.

    I upgraded to 3.7.2 on a local test version and it did not solve the problem.

  2. Macropiper
    Member
    Posted 4 years ago #

    I'm guessing its an issue with the permalinks you are using, what permalink structure are you using?

    If it is simple, as in consisting of only two items or less, it could be conflicting with the permalinks set up by the e-commerce plugin.

  3. Warwick Booth
    Member
    Posted 4 years ago #

    I am using the "custom" structure like so
    /%category%/%postname%/

    I changed it to the "Day and Name" structure as well and tested it with that.

    Unfortunately it is still showing the same posts on every page

  4. beppemarchetti
    Member
    Posted 4 years ago #

    you can try this:

    1. login to wordpress
    2. go to the plugin's settings
    3. click on settings>admin
    4. at the very bottom of the page, click on "update page urls"
    5. cross fingers! ;)

  5. Justinabes
    Member
    Posted 4 years ago #

    Tried the above recommendation, URL Settings - settings options updated.
    Pagination still isn't working on the products page.
    http://www.originroasting.feedmydemo.co.za/the-coffee/products-page/

    WordPress 2.8.4
    WP Shoping Cart Version 3.7.2
    WP-PageNavi Version 2.50

  6. batikandgift
    Member
    Posted 4 years ago #

    I am having the same problem, here's a brief of my setup

    WordPress Version 2.8.4
    WP E-Commerce Version 3.7.4
    Permalink settings: Day and name

    From the Shop pagination it shows double 'shop' url:
    http://localhost/shop/shop/page/2/

    where the correct one should be just

    http://localhost/shop/page/2/

    I also tried to fix it from Products -> Settings -> Admin
    Update Page URLs and Fix Product Group Permalinks
    Still doesn't seems to work correctly.

    any ideas how to fix this problem?

    Thanks in advance

  7. S.K
    Member
    Posted 4 years ago #

    You may try your luck with LesterChan's forum for Pagenavi.

    S.K

  8. batikandgift
    Member
    Posted 4 years ago #

    Previously the pagination of WP E-commerce was working well before I change the Reading Settings to static page.

  9. batikandgift
    Member
    Posted 4 years ago #

    Found the solution,

    Under wp_options table search for option_name = wpsc_category_url_cache
    delete its contents and hopefully your pagination & categories link will be back to normal.

  10. zizishop
    Member
    Posted 4 years ago #

    @ batikandgift: I cant find wpsc_category_url_cache in wp-option,..I use wp-e-commerce ver 3.6.12,..anu suggestion?...do you indonesian batikandgift?

  11. daveevolve
    Member
    Posted 4 years ago #

    Has anyone found a solution to this. I tried deleting the information that was in the database under the option_name, but that didn't solve the problem. I am using wp version 2.8.4, wp-ecommerce 3.7. It will work for me with the permalinks set to default.

  12. Logan1_br
    Member
    Posted 4 years ago #

    I have the same problem using wp version 2.8.4, wp-ecommerce 3.7

    I can see the product list but if I click on the product I recieve a 404 error.

    I've tried all the suggestions to fix it. Anyone had a better luck?

    Tks

  13. Logan1_br
    Member
    Posted 4 years ago #

    I fixed reinstalling the plug-in!

  14. demonite
    Member
    Posted 4 years ago #

    I had the exact same issue. After playing around I discovered that editing a category name, caused the link to the details product page to be broken.

    The solution was to delete the category then recreate it, but then you'd have to go back and update all the products that were related to that category again. It's tedious but it worked...

    Dwain Browne
    http://www.candevservices.com

  15. rdmoore1000
    Member
    Posted 4 years ago #

    Correction to Logan1_br. You only have to deactivate the plugin and then reactivate it. It worked for me.

  16. niaomi24
    Member
    Posted 4 years ago #

    Hey guys, I think I have this same problem. Pagination works on the default product page but does not work on the individual categorized pages. I have tried the options on here but none have worked.

    I have limited php knowledge and would not know where to find wp_option, I've did google search but I dare not mess with the database, I just don't have the experience - I'm just a designer really.

    Please, if anyone has found another solution hopefully you'll share. I've spent ages on my site only to come across this one hiccup.

    Cheers!

  17. niaomi24
    Member
    Posted 4 years ago #

    Just to make this a little easier when I use [wpsc_products category_url_name='retro-cards'] or [wpsc_products category_url_name='kids-cards'] etc etc these category specific page don't display pagination where as the default product page [productspage] works fine with pagination.

    Please help guys, I'm desperado!

  18. niaomi24
    Member
    Posted 4 years ago #

    Oh, I figured this darn thing out. Pretty good thing as I've search for help on this for days.

    Anywayz, for anyone who may stumble across the same problem, here's a solution -

    In order for pagination to work on the category specific product pages i.e when you use [wpsc_products category_url_name='yourproductname'] to call the products on another page other than the default product page, make sure the name of your category (created through wp ecommerce settings) matches the name of the page you are calling the products.

    Example if you create a product group called magicians in wp ecommerce, make sure the page you display [wpsc_products category_url_name='magicians'] is also called magicians and not magicians5 or something else.

    I use custom permalinks /%category%/%postname%/ - I'm not sure if this makes a difference but there you go.

    Sorry, I don't know how to explain this better but if anyone needs help just PM me.

  19. Vezy
    Member
    Posted 4 years ago #

    For those of you who land on this - follow batikandgift's suggestion above

    Found the solution,

    Under wp_options table search for option_name = wpsc_category_url_cache
    delete its contents and hopefully your pagination & categories link will be back to normal.

    For those of you who don't have a clue what he is on about (you were a few on here i see), you access your MySQL, then extend you database by clicking on it, and click on wp-options table.(literally) Then find
    wpsc_category_url_cache in the option_name list. Click on the pencil to edit and empty the information in the comment box.
    This just fixed things for me.
    Good luck!

  20. marcelnothdurft
    Member
    Posted 4 years ago #

    Pfffff, beppemarchetti it worked for me, thanks so much!

  21. jhall_3rd
    Member
    Posted 4 years ago #

    I have exactly the same issue that batikandgift had -- double URL is causing a 404! BUT, i don't have dufferent categories -- all products are together. I therefore do not have a "wpsc_category_url_cache" in my DB and am at a complete loss as to how to proceed. I have tried de-activating and then re-activating wpsc to no avail. I've "fixed products URLs" , turned-off custom permalink structure.. nothing foxes this. Instinct does not respond. Re-installing the plug in will be a last resort as I will have to completely re-build the #$%^ store!

    anyone?

  22. jhall_3rd
    Member
    Posted 4 years ago #

    Vezy - do you think there is a similar url cache for set-ups that do not use separate categories for the products?

  23. jhall_3rd
    Member
    Posted 4 years ago #

    batikandgift fix does the trick! I wasn't at first able to find DB DB row with "wpsc_category_url_cache" -- simply beacuse i didn;t se that there were more than one page to the table (!). Mine has 10 pages -- row 803 held this value. Follow Vezy's advise and erase the values in the comments block ... btw, mine looked like:

    a:3:{i:0;s:0:"";i:4;s:14:"lessons-on-dvd";i:3;s:22:"lessons-for-ipodiphone";}

  24. genim
    Member
    Posted 4 years ago #

    you can try [wpsc_products category_url_name='categoryname' number_per_page='10']

  25. dicalva
    Member
    Posted 4 years ago #

    Still having problems after reading all of your help:

    Please check out here: http://www.luxembourgartistsforhaiti.lu/products-page/

    I get "There are no products in this group." :-(

  26. Lee Willis
    Member
    Posted 4 years ago #

    That's the main products pagee - you shouldn't need a shortcode to show products there.

    How many products have you added in the admin area? What categories have you added them in, and what have you got set for "Select what product group you want to display on the products page" (Under Products >> Settings >> Presentation >> Product Page Settings)

  27. dicalva
    Member
    Posted 4 years ago #

    Hi Lee, thanks for your quick response :-)
    OK, I took the shortcut away from the page again.

    I have two products, a T-shirt and a cap and I have created under the categories group two new categories named tshirt and cap and I have selected (just now) all products under Product Page Settings - because it was on "exaumple brands" before...

    But now, even the sentence:"here are no products in this group." has disapeared and nothing is showing :-(

  28. dicalva
    Member
    Posted 4 years ago #

    Hi Lee again, It is showing now BUT I have a style problem and the products are way down there after scrolling a mile ... puh!!! At least it IS working now and I have to find my styling Problem now :-/ ... one problem at a time :-P

  29. kiko0850
    Member
    Posted 4 years ago #

    I had this problem also, all i had to do was change my custom permalink to /%category%/ and that fixed my error with the pagination not going to the correct place

  30. ALIENIGENA777
    Member
    Posted 4 years ago #

    HI FRIENDS...
    I have a problem, i hope you can help me.
    when i click in the category link of products,I can't see my store if i am logout, but if i am registred all work fine.
    some one help?

Topic Closed

This topic has been closed to new replies.

About this Topic