WordPress.org

Ready to get started?Download WordPress

Forums

WP eCommerce
[resolved] [Plugin: WP e-Commerce] Freezes on transaction results (5 posts)

  1. dowsed
    Member
    Posted 2 years ago #

    Hi There,

    I've just successfully installed the plug-in and gotten all the features I want working. The only problem I am having is that the transaction results page doesn't refresh to a completed payment message once you "confirm payment". This is even though the payment has gone through too.

    Is this a bug that anyone else has noticed? Is it flagged for the next update? Or is it something that I need to resolve.

    Cheers

    http://wordpress.org/extend/plugins/wp-e-commerce/

  2. Justin Sainton
    Member
    Plugin Author

    Posted 2 years ago #

    Hi there,

    This is not an issue I have heard of elsewhere. Generally if there is a successful transaction, the transaction results page will reflect that.

    What payment gateway are you using? Is it a custom module or something native to the plugin?

  3. usernameSteve
    Member
    Posted 2 years ago #

    Hi dowsed,
    I had same problem with the paypal express checkout module, on a test site with XAMPP. It turned out it was timing out when doing the final communications with paypal I think. I altered timeout value in file plugins/wp-e-commerce/wpsc-merchants/paypal-express.merchant.php from 5 to 20 and that worked for me.
    Whatever you are using as your payment module may be a similar solution.

    To anyone encountering this with the paypal express module---
    From memory the code appears to check for the timeout error but then doesn't seem to finish handling the error completely. Hopefully justinsainton will see this and follow it up.
    The timeout value was in 2 separate places in the file and I changed both.
    Search the file for "timeout" and you will get both

  4. Justin Sainton
    Member
    Plugin Author

    Posted 2 years ago #

    I'll add a ticket for increasing the general timeout settings across the board in WPeC

    http://code.google.com/p/wp-e-commerce/issues/detail?id=1110

    That said, in the meantime, you can filter all timeout calls through the WP HTTP API. You'd want the 'http_request_args' filter. Here's a quick example you could throw in your theme's functions.php file to ensure all requests have a timeout of 20 seconds, no matter what.

    function js_increase_all_http_timeouts( $args, $url ) {
    
    	$args['timeout'] = 20;
    
    	return $args;
    
    }
    
    add_filter( 'http_request_args', 'js_increase_all_http_timeouts', 10, 2 );

    Certainly, you could limit it by the URL if you'd like to with the second parameter there. But this code would enable you to experience the same fix without hacking core.

  5. GP23
    Member
    Posted 1 year ago #

    Just wanted to say that increasing the timeout resolved this issue for me.

    Many thanks for posting the solution guys.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic