WordPress.org

Ready to get started?Download WordPress

Forums

WP e-Commerce Featured Product
Product Thumbnail Showing "No Image" (5 posts)

  1. cassihl
    Member
    Posted 1 year ago #

    I'm working on an ecommerce site and trying to use the Featured Product plugin. It works well, except for the thumbnail image. It's not displaying the product's image, instead it's showing a generic wordpress shopping cart image. I have featured images set for all of my products, and the thumbnails show up fine on the products pages & single product pages. Did I miss a step somewhere? Is there something else I need to do to get the featured images to show up in the widget?

    Thanks!

    http://wordpress.org/extend/plugins/wp-e-commerce-featured-product/

  2. zorgbargle
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,
    I am unable to reproduce the problem. Is your site live - can you provide a link that demonstrates the issue? Also, could you let me know which version of WP e-Commerce you are using.

    I assume you've added the "Featured Product" widget, and checked the "Show product image" check box. You could try playing with the different image sizes in the widget settings.

    Cheers,
    Z

  3. MSD123
    Member
    Posted 1 year ago #

    Hi,

    I have a similar problem only some of the images work and some dont - http://www.myspecialday.co.nz - all products have set featured images and using Version 3.8.8.5 of wp ecomm

    Thanks

  4. cassihl
    Member
    Posted 1 year ago #

    zorgbargle - thanks for your reply. My client has decided they don't want the featured product in the sidebar after all, so this isn't an issue for me any more. I never figured out the problem though, so if this can help anyone else, here's the info you requested:

    Also, could you let me know which version of WP e-Commerce you are using.

    - 3.8.7.6.2

    I assume you've added the "Featured Product" widget, and checked the "Show product image" check box. You could try playing with the different image sizes in the widget settings.

    - yes, this is what I did, and tried a few different image sizes.

  5. zorgbargle
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Thanks cassihl for information.

    MSD123, thank you for providing a demonstration of the issue, unfortunately I am still unable to reproduce the problem on my dev server.

    A couple of options:
    1) The 'Featured Product' widget uses the same query that WP e-Commerce's 'Latest Product' widget uses to find the product image. Could you try some of the official WP e-Commerce widgets? It would be useful to confirm if they show the same generic image for the same products, or if they behave as you would expect.
    2) I've added some debug code to a development version of the 'Featured Product' plugin that prints some html comments inline with the widget. These comments are only visible when you view the HTML source. If you are able to assist by installing this version of the plugin, I may be able to see what's going wrong. Please contact us via the contact form (http://www.phenomenoodle.com/contact-us/) and I will email you the dev version of the plugin.

    Cheers,
    Z

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic