WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP e-Commerce] Error Adding Products %wpsc_product_category% permalink (3 posts)

  1. OptimizeWorldwide
    Member
    Posted 2 years ago #

    We are getting a 500 Internal Server error when we try to add a new WP e-commerce product. I am noticing that the category in the permalink is not populating.

    Our permalink structure in WP Admin looks like this before publishing: http://domain.com/wine-store/%wpsc_product_category%/a-new-product/

    Even though we are receiving the server error, it is technically publishing the new products and we can manage/edit the new product after the error occurs.

    Any help would be much appreciated :)

  2. freddyfromparis
    Member
    Posted 2 years ago #

    You should have solved this problem, but for others who could get the same, just notice that the permalink is displayed when publishing your product (or post). A draft post has no permalink.
    In order to check it without publishing it for anyone, set it as "private".

  3. kalshyre
    Member
    Posted 1 year ago #

    I had a similar problem. When I tried to use WPEC permalink, the links to single product page that appear either
    - on category page
    - on the 'view product' link (on the edit product page)
    - in the breadcrumbs (not the WPEC one)
    would be of this form : http://website.com/product-page/%wpsc_product_category%/product-slug
    Changing manually the %wpsc_product_category% would work, so the problem is coming from the function returning the permalink (the WPEC one and the WP one that it calls)

    For me the problem was apparently caused by a conflict with the plugin qTranslate slug. It works after deactivating the plugin. Need to see if there are other bugs caused by not using it.

    Versions : qtranslate slug 1.1, qtranslate 2.5.31 (not the latest), WPEC 3.8.9.5, WP 3.5.1, localhost installation

Topic Closed

This topic has been closed to new replies.

About this Topic