WordPress.org

Ready to get started?Download WordPress

Forums

WP e-Commerce
[resolved] All pages on website display the products page! (7 posts)

  1. georgiamarie
    Member
    Posted 1 year ago #

    I have installed wp e-commerce and added 2 test categoriesm with one product each. Looks good.

    Except for some reason ALL pages on my website, except for the home page, (FAQs, about us, class descriptions etc) just display the products list instead. I am not sure when it started happening. The site is in dev on my local machine, only.

    I am using a theme from template-help.com and I have no other plugins installed yet. I have edited the wpsc-single_product.php and wpsc-products_page.php because I wanted to display a title and tweak a few minor things.

    Anyone had this issue before, or have any ideas to help me solve it?

    Any help would be appreciated. Thanks!

    http://wordpress.org/extend/plugins/wp-e-commerce/

  2. georgiamarie
    Member
    Posted 1 year ago #

    Update:

    I ran a sql file to restore my DB to point before I installed wp e-Commerce. All pages (about us, FAQs etc) behave as normal, and work fine.

    I activated wp e-Commerce, and refreshed the test site. All pages displayed 'there are no products in this category' message. I deactivated and all pages now just display the home page.

    I am running the sql file again to revert to pre-wp-e-Commerce state.

    From this test I have narrowed down the cause of the problem to be this wp e-Commerce plugin. I am not sure if it's due to a theme clash or what, though.

    I am going to continue developing my website and try out a different shop plugin, for comparison.

    I am not going to mark this thread as resolved, in case anyone else can offer some insight as to why this happened, or how to avoid it in future.

    Thanks :)

  3. constantine.johny
    Member
    Posted 1 year ago #

    Hi, I had the same problem, but the solution is quite simple.

    Go to /wp-admin/options-permalink.php and simply click on Save changes. It will rebuild all of your permalinks on the page and everything should work OK (in my case it worked ;) ).

    Or try to change the permalinks to the "?p=123" (default), Save, and then change to the value you use, and save again :)

  4. georgiamarie
    Member
    Posted 1 year ago #

    Thanks constantine!

    Clicking 'save changes' in the permalinks page worked perfectly.
    Don't know why I didn't think of it before! :D

  5. AmandaKulik
    Member
    Posted 1 year ago #

    Can you keep the wp e-commerce installed and still click permalinks to reconstruct site?

    I installed, but had to uninstall because it messed the entire site up.

    Thanks!

  6. constantine.johny
    Member
    Posted 1 year ago #

    Yep, I was able to go to permalinks while e-commerce was still installed. It only messed my static pages, not the administration section.

  7. oakstmarketing
    Member
    Posted 1 year ago #

    You are a flippin genius! Thank you!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic