WordPress.org

Ready to get started?Download WordPress

Forums

WP eCommerce
[Plugin: WP e-Commerce] 404 Error: Checkout, Transaction Results, Your Account Pages (24 posts)

  1. wpzee
    Member
    Posted 3 years ago #

    My Checkout, Transaction Results and Your Account Pages are not showing up. Consequently, I am not able to do a test transaction. Arghhhhh!

    I'm reading previous postings. I'm on page 5 at the moment working back to page 17. I've read a couple of references to this problem. Although, none have helped me so far.

    Any ideas? Anyone?

    Thanks in advance!

    wpzee

    http://wordpress.org/extend/plugins/wp-e-commerce/

  2. wpzee
    Member
    Posted 3 years ago #

    Hi again!

    Yay! I figured out what the problem is. Although, identifying the problem has presented me with a brand new problem to solve. I hope someone out there can still help me!

    OK, I'm getting a 404 Error for the Checkout, Transaction Results and Your Account Pages because currently the URL is "http://www.heirloomtomatoplants.uni.cc/heirloom-tomato-plants-store/checkout.html". This is due to something I did when I set up the site. The URL should be, "http://www.heirloomtomatoplants.uni.cc/heirloom-tomato-plants-store/checkout". The .html extension is causing the "problem", apparently.

    I know this is the problem because when I enter, "http://www.heirloomtomatoplants.uni.cc/heirloom-tomato-plants-store/checkout", the page comes up fine - as do all the others.

    Which lead to the new problem I am having: how do I change the URL to my pages back so they no longer end with a .html extension. FYI, changing the permalinks back to my usual custom (/%postname%/) didn't fix it.

    Anyone? Bueller?

  3. gekkewaus
    Member
    Posted 3 years ago #

    Hi,

    I've got the same problem with the checkout page. I'm Dutch so my English isn't that good. What did you exactly to fix the problem with the 404 error?

    Thanks.

  4. gekkewaus
    Member
    Posted 3 years ago #

  5. wpzee
    Member
    Posted 3 years ago #

    Hi gekkewaus, hoe gaat het? ;-)

    Don't get excited, my friend. I don't really speak dutch! I used Google translator. ha ha. OK, back to business.

    I discovered that when I remove the ".html" from the URL, I can see the checkout page (and the other pages) in my browser.

    There is ".html" at the end of my URL's because I customized my permalinks to /%postname%.html/. Now, I know if I plan to add a shopping cart it may not a good idea to customize my permalinks this way.

    I hope my reply helps. In the meantime, I will look at your site.

    good bye voor nu :-)

  6. wpzee
    Member
    Posted 3 years ago #

    Hello again gekkewaus,

    OK, I just came from your website, http://firstclassverhuur.nl/. And yes, when I go shopping (Winkelwagen) and then click Afrekenen to checkout, I get a 404 error. This is similar to my problem. But not exactly.

    The checkout information is available. It's just at the bottom of the page. The checkout page is not completely empty which is what I am experiencing. But again, like my website, for some reason you're still getting a 404 error at the top of the page.

    By the way, I realize I did not tell anyone where to find my website. Perhaps that could help me get this problem solved. Go to: http://www.heirloomtomatoplants.uni.cc

    I think if I find the answers to my problem, it could help you, too. I will let you know if I do.

    Bye for now.

  7. gekkewaus
    Member
    Posted 3 years ago #

    Hi,

    Thanks for replying.

    Do you think a total reset could word? Delete the plug-in and reinstall? I tried everything and the the codes of e-commerce aren't that easy to understand and edit. There are very much references to other files.

    Thanks for your help.

  8. wpzee
    Member
    Posted 3 years ago #

    Hi gekkewaus,

    Well, I am happy to announce I have solved the problem of getting 404 errors and my shopping cart and other pages not showing up because the URL ended in .html.

    I was able to permanently remove the html extension by installing another plugin called, Permalinks Editor, which can be found here: http://wordpress.org/extend/plugins/permalink-editor/

    After you install Permalinks Editor, there should be an option to change the permalinks. Go to admin --> page --> edit and then look for the "customize" button next to the permalink. Change that.

    But then note, I found it necessary to deactivate the plugin and then reactivate it again for everything to work correctly.

    Now, to answer your question gekkewaus, you could try uninstalling and reinstalling the plugin. Although, again, what I found is I had to deactivate and reactivate for many of the changes I made to actually work!

    I did not actually uninstall/reinstall the plugin. I simply used the deactivate/reactivate option(s). Too often just updating did nothing. Not sure why. But that was my experience.

    As far as the problem you are having, gekkewaus, I don't know if this is really going to help you. Your links don't appear to have .html at the end.

    However, if I may so boldly suggest, you may want to customize your links. Make them "prettier" for SEO purposes.

    So instead of http://firstclassverhuur.nl/?page_id=130, you could customize the URL to be http://firstclassverhuur.nl/fotogallerie

    Just a suggestion. :-)

    One more thing. You may find some help for your problem in other programming forums. I would think there are some in your country. I fancy http://forums.digitalpoint.com/forumdisplay.php?f=110. That's a link to the WordPress section of the Digital Point Forum.

    If I find any answers for you, I'll come back and let you know.

    Ciao.

  9. wpzee
    Member
    Posted 3 years ago #

    hi gekkewaus, how are you?

    I'm just checking back in to see how things are going for you and your website. Did you ever figure out what is causing the 404 Errors?

  10. webdesignstudiotoronto
    Member
    Posted 2 years ago #

    I am having same error message but different issue, can someone look at it for me? Thank you very much in advance.

    When I checkout, I will be brought to
    https://www.xiexianhui.com/~webdesq0/~webdesq0/webdesign/products-page/checkout/
    And here the 404 Error File Not Found will be displayed under Bluehost

  11. webdesignstudiotoronto
    Member
    Posted 2 years ago #

    I also tried removing the /~webdesq0/~webdesq0/, I tried removing one or both, no use

  12. webdesignstudiotoronto
    Member
    Posted 2 years ago #

    To avoid interfered by other plugins, this is the only plugin in the blog, there is no even inactive plugin.

  13. Ikkichi
    Member
    Posted 2 years ago #

    Hey Guys,

    Hows it going ?

    I seem to be having something Similar hopefully some one can help out .
    When I add a product and click on the product on the website it comes back with an :

    Error 404 - Not Found

    We're very sorry, but that page doesn't exist or has been moved.
    Please make sure you have the right URL.

    If you still can't find what you're looking for, try using the search form below.

    Not sure what to do pitty word press doesn't have a live helper .

    Thanks
    Ryan
    http://www.comicbookjunkyblog.com

  14. djddeep
    Member
    Posted 2 years ago #

    I have the same problem, the only difference is that the Transaction Results page is showing nothing.

    I get redirected to a page products-page/transaction-results/?sessionid=5141321100183 with a session id but this page does nothing. The products are still in the widget.

    How can I fix this?

  15. Atataya
    Member
    Posted 2 years ago #

    me too.
    i have 404 error page when click checkout how to do this?
    help me please...
    my site cheaplyshop.com

    thank you for next reply.

  16. Ikkichi
    Member
    Posted 2 years ago #

    Seems to be working lol

  17. Ikkichi
    Member
    Posted 2 years ago #

    Ok but I see yer checkout is messed up

  18. Atataya
    Member
    Posted 2 years ago #

    thank you Ikkichi and now can't create cart ...that it sad story with e commerce site

  19. Ikkichi
    Member
    Posted 2 years ago #

    Have you tried Deleting the current WP Ecommerce and installing the new one ?

  20. Atataya
    Member
    Posted 2 years ago #

    I try to do this. but is not work maybe i should use another plugin You suggested? Before this i try a oS-Ecommerce plugin but hostgator do not support because use the php version 3.4 i can't upgrade it.

    Thank you again Ikkichi

  21. harvestsum
    Member
    Posted 2 years ago #

    On one site I successfully worked around the /checkout.html permalinks problem by installing a plugin called Simple 301 redirects and redirecting /checkout.html to /checkout (also transaction-results.html, /your-account.html, /your-account.html?edit_profile=true, and your-account.html?downloads=true) Its not a pretty fix but it seems to work ok so far.

  22. Al_Def
    Member
    Posted 2 years ago #

    I found it! I hope it will be useful, to someone. In my situation by pressing of the checkout button the e-coom redirected me on hostname/product-page/transaction-results/?sessionid=xxxxxxxxxxx
    But we need to replace this on hostname/shop/transaction-results/?sessionid=xxxxxxxxxxx !!! I trying to correct this one in code now.

  23. Al_Def
    Member
    Posted 2 years ago #

    Yes! As usual the problem was solved simply
    ! The page "transaction-page" it shall be published and the mainpage of shop shall be her parent. Don't delete default pages created e-commerce. sorry for my english, Bros!!

  24. Al_Def
    Member
    Posted 2 years ago #

    And if the product page has been changed you need to change it linkname to "products-page" too!!!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic