WordPress.org

Ready to get started?Download WordPress

Forums

WP-dTree
issues with taxonomy.php file? (3 posts)

  1. domofactor
    Member
    Posted 4 years ago #

    so, i had recently transfered my wordpress over to a new domain and after i install the wp-dtree plugin i get an error while making a post, or delete things from trash. normal things of that nature. i'm not quite sure what the error is, just that wp-dtree is the plugin causing it. here's a printscreen of the error i get when i try to edit a post. does anybody have any ideas? thanks.

    also i tried reloading a fresh copy of the wp-includes and wp-admin directories and no luck there either:(

    -Terrell

    http://i12.photobucket.com/albums/a236/sftmb/Screenshot.png

  2. andrewkro
    Member
    Posted 3 years ago #

    Hi, I had the same exact issue here.

    Every time the post is auto-saved or saved I got the error:

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /home/content/u/t/e/utentehosting/html/it/wp-includes/taxonomy.php on line 2411

    Warning: implode() [function.implode]: Invalid arguments passed in /home/content/u/t/e/utentehosting/html/it/wp-includes/taxonomy.php on line 2411
    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') AND post_type IN ('post') AND post_status = 'publish'' at line 1]
    SELECT object_id, term_taxonomy_id FROM wp_term_relationships INNER JOIN wp_posts ON object_id = ID WHERE term_taxonomy_id IN () AND post_type IN ('post') AND post_status = 'publish'

    Warning: Invalid argument supplied for foreach() in /home/content/u/t/e/utentehosting/html/it/wp-includes/taxonomy.php on line 2418

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/u/t/e/utentehosting/html/it/wp-includes/taxonomy.php:2411) in /home/content/u/t/e/utentehosting/html/it/wp-includes/pluggable.php on line 890

    Is there a fix?

  3. ulfben
    Member
    Plugin Author

    Posted 3 years ago #

    Something is seriously botched with your installations. :P

    But try the new version. It doesn't generate the cache untill it absolutely needs to (eg. on site visits).

    And if it still doesn't cooperate you can turn the cache off.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic