WordPress.org

Ready to get started?Download WordPress

Forums

WP-Cycle
wp cycle slider; can the slider be positioned on a page? (4 posts)

  1. nigelpengelly
    Member
    Posted 2 years ago #

    Hi,

    Does anyone, and excuse me if I'm not up to scratch here, know if there is a way of making the wp cycle slider position itself on the right of a page.

    It always seems to go to the left.

    Thanks.

    http://wordpress.org/extend/plugins/wp-cycle/

  2. katjo15
    Member
    Posted 2 years ago #

    Hello,
    I also need some assistance with this. Here is the website I am working on:
    http://www.lethalamounts.com/dev

    You can see that the slider is appearing above the logo on the left. I added the following code to my css stylesheet to reposition my wp-cycle slider to the right side of my header:

    #rotator {
    position: absolute;
    width: 550px;
    height: 120px;
    margin-left: 475px;
    margin-top: 7px;
    padding: 0;
    overflow: hidden;
    }

    Using Chrome's developer tools, I am seeing that wp-cycle adds it's own code to a separate stylesheet that is overwriting my #rotator code from above. The code that's overwriting mine (therefore keeping it aligned left) is:

    <style type="text/css" media="screen">
    #rotator {
    position: relative;
    width: 550px;
    height: 150px;
    margin: 0; padding: 0;
    overflow: hidden;
    }
    </style>

    Again, using Chrome's developer tools, when I "uncheck" or "deselect" the default positioning code, mine takes over and wp-cycle is positioned to the right (the way I want it to look). I cannot, however, find the stylesheet that is overwriting my code! Has anyone else had this problem?? Do you know where wp-cycle adds that positioning code? I am using my ftp server to look through all the files and cannot find this code. If I can locate the file, I can just delete their code and the slider will position correctly and life will be grand. Help please!

    Thanks.

  3. katjo15
    Member
    Posted 2 years ago #

    Nigelpengelly,

    Try adding the following code to the "header" section of your css stylesheet. Make sure you use your correct dimensions, div id name, etc. Let me know if you have the same problem as me. Thanks!

    #rotator {
    position: absolute;
    width: 550px;
    height: 120px;
    margin-left: 475px;
    margin-top: 7px;
    padding: 0;
    overflow: hidden;
    }

  4. katjo15
    Member
    Posted 2 years ago #

    Hi again,
    I am still unable to locate the stylesheet that wp-cycle is adding its own positioning code to, but I was able to correctly position my rotator on my website: http://www.lethalamounts.com/dev

    I added !important; at the end of each line.

    #rotator {
    position: absolute !important;
    width: 550px !important;
    height: 120px !important;
    margin-left: 475px !important;
    margin-top: 7px !important;
    padding: 0 !important;
    overflow: hidden !important;
    }

    Hope this helps someone!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags