WordPress.org

Ready to get started?Download WordPress

Forums

WP-Cycle
[resolved] uploading image error (3 posts)

  1. vitamineg
    Member
    Posted 2 years ago #

    Hello, i have a version of WP-Cycle on a localhost and one live.

    One the live install, when i try to upload an image, i get the following errors:

    Warning: basename() expects parameter 1 to be string, object given in /html/wp-content/plugins/wp-cycle/wp-cycle.php on line 129

    Warning: Division by zero in /html/wp-content/plugins/wp-cycle/wp-cycle.php on line 137

    Catchable fatal error: Object of class WP_Error could not be converted to string in /html/wp-includes/media.php on line 250

    Thoughts?

    http://wordpress.org/extend/plugins/wp-cycle/

  2. vitamineg
    Member
    Posted 2 years ago #

    FIGURED IT OUT! MY BAD - BLONDE MOMENT

  3. kennyknapp
    Member
    Posted 2 years ago #

    What did you find? My client's installation just started reporting two weird errors when they try uploading images.

    Warning: getimagesize() [function.getimagesize]: Filename cannot be empty in D:\Hosting\4797465\html\wp-content\plugins\wp-cycle\wp-cycle.php on line 117

    Warning: unlink() [function.unlink]: No such file or directory in D:\Hosting\4797465\html\wp-content\plugins\wp-cycle\wp-cycle.php on line 121

    Sorry, but the file you uploaded does not seem to be a valid image. Please try again.

    I'm definitely using valid images, in fact, I tested it with an image they already had in their uploads folder. I checked permissions and applied 755 to wp-content/uploads and all the sub-folders. I'm using Version 0.1.12

    I'm trying to figure out if they installed another plugin that is conflicting with WP-cycle or what else might have changed. This has been working fine for over a year and now it's not. I'm not sure when it changed, though.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags