WordPress.org

Ready to get started?Download WordPress

Forums

WP-Cycle
Cycle Images enlarged/stretched when changed (11 posts)

  1. James M
    Member
    Posted 3 years ago #

    I'm having an issue with wp-cycle I can't figure out.

    In IE 8 when the WP-Cycle image change, for some reason it is enlarged and gets cut off within the rotator box.

    The initial image shown is fine, but all the images cycled get enlarged, even when it gets back to the first image, it is then stretched too.

    The link to the site is http://tinyurl.com/2759v87

    It's fine in Firefox, Chrome and other versions of IE.

  2. riversatile
    Member
    Posted 3 years ago #

    Hi,

    Make sure your images are the same dimensions than the WP-CYCLE settings (wordpress settings panel)

    Make sure the CSS attributes that correspond to "Rotator DIV ID" you've chosen are corrects

  3. riversatile
    Member
    Posted 3 years ago #

    I saw this parameters in source file of site :
    It seems all of them are corrects...

    Rotator DIV ID :

    <div id="rotator">
    <img src="http://jha-techspace.com/wp-content/uploads/2010/10/flexfurn-resized.jpg" width="590" height="235" class="20101016055108" alt="" />
    <img src="http://jha-techspace.com/wp-content/uploads/2010/10/clientlist-resized.jpg" width="590" height="235" class="20101016055318" alt="" />
    </div>

    CSS :

    <style type="text/css" media="screen">
    	#rotator {
    		position: relative;
    		width: 590px;
    		height: 235px;
    		margin: 0; padding: 0;
    		overflow: hidden;
    	}
    </style>

    So, I don't understand what's happening !
    I've tested your site on IE8, I've the same thing than you.

  4. riversatile
    Member
    Posted 3 years ago #

    Try to change the effects you've chosen in the WP-CYCLE settings panel

  5. James M
    Member
    Posted 3 years ago #

    Hi, thanks for your responses and checking it out so thoroughly.

    I tried changing the transition settings with no luck.
    Also made new images, w/ the exact dimensions and still no luck.

    Just another IE things, :) It's weird be cause it's just stretching horizontally. Vertically the height of the images is fine. And it's only on change, so it has to be something in the JS I'd assume.

    So, not too big a deal, just wanted to see if there was something I could do to fix it. I know there's other plugins similar to this one, I'll try to find one.

    Thanks for your help, really appreciated!

  6. lightfoot33
    Member
    Posted 3 years ago #

    I am having the exact same problem. I have tried changing the styles; I have tried changing the settings; I have manually resized the images so that everything matches, but the images are still distorted/stretched horizontally in IE8. Has anyone else had this problem?

  7. lightfoot33
    Member
    Posted 3 years ago #

    After some more searching, I have found that adding a link fixes the distortion issue... Although I am still unsure how to fix the issue if you don't want the slideshow images to link to anything.

    More information here: http://wordpress.org/support/topic/wp-cycle-image-size-bug-in-internet-explorer-8-ei8

  8. astromono
    Member
    Posted 3 years ago #

    Hey guys, I was having the same issue as you, but then I figured out that when you try uploading the images and then change the size of the image in the settings, the program doesn't get it properly.

    In other words, you have to set the size of your images in WP-Cycle before uploading the images in order for them to be displayed correctly.

    Hope this helps!

  9. James M
    Member
    Posted 3 years ago #

    I found the fix to my issue was setting a link for all the images in rotation. Before, I just had the slide show and they were not clickable links.

    I found the post lightfoot33 mentioned which said to do include a link for each image. In my case i just used '#' so it would not be a real link.

    That seemed to fix the stretching issue.

    Thanks for you help!

  10. mavaddat
    Member
    Posted 3 years ago #

    I actually know the answer to this. The problem is that although wp-cycle deletes image off your server, it doesn't correctly remove the corresponding reference in the database. Therefore, if you uploaded an image at a lower scale-setting, then re-uploaded the image after increasing the scale-setting, your browser looks for the image and pulls it up from the cache.

    If you rename the image (or change its link) and upload it, you should avoid the problem.

  11. AustinThemes
    Member
    Posted 3 years ago #

    Here's an easy (but hackish) fix that solved mine perfectly:
    Just set a max-width for the images.

    #rotator img{max-width:960px;}

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags