WordPress.org

Ready to get started?Download WordPress

Forums

WP Customer Reviews
Admin Panel Not showing Up (8 posts)

  1. mymactek
    Member
    Posted 2 years ago #

    Hello,

    We downloaded the plugin and nothing is showing in the admin panel except the " About WP customer reviews " and " Notify me...".

    Please assist asap !
    Thank you so much

    http://wordpress.org/extend/plugins/wp-customer-reviews/

  2. javierojuel
    Member
    Posted 2 years ago #

    The same happens to me. Could you please help me with this issue?

    Thank you in advance and greetings from Spain!

  3. ebauman25
    Member
    Posted 2 years ago #

    Same here. Could you please help us with this issue?

  4. xtrmerik
    Member
    Posted 2 years ago #

    I had everything working, but then decided that I wanted to change my theme. Upon changing my theme to iTheme2, the button for the customer reviews plugin no longer shows up in the admin panel. I now have no way to moderate the reviews I am getting. What do I do?

    I also noticed that no matter what I select under the setting- Enable Business hCard output on:, it automatically changes back to Never. :(

  5. xtrmerik
    Member
    Posted 2 years ago #

    As a follow up, I activated other themes and the button reappears. It seems as though there is some conflict between iTheme2 1.1.9 by Themify and the customer reviews plugin. If someone could help me find and resolve the problem I would appreciate it, since I like this theme.

  6. javierojuel
    Member
    Posted 2 years ago #

    HEY! I found the problem. It's me!!!!

    In the configuration page, there is a text where it asks to you of you have contributed. YOU HAVE TO PRESS YES O NO THANK YOU IN ORDER TO ACCESS THE CONFIG PARAMETERS!

    I must learn how to read!

  7. xtrmerik
    Member
    Posted 2 years ago #

    Yeah, that's not my problem. I can get to the configuration page and adjust settings for the plugin just fine. My problem is that with the particular theme I am using, the button on the left sidebar that gives you access to moderating reviews is MIA. If anyone has any ideas for me I would be grateful.

  8. xtrmerik
    Member
    Posted 2 years ago #

    So after digging through the code I discovered what the problem was. The default value set for the admin button that determines placement is "50". The theme I was using had it's own theme button with a value of 50 that was overriding the moderation button. I determined that if I gave it a value of 45, it appeared under the "Comments" button as intended, and above the button that my theme was adding for itself. If you are not seeing the "Customer Reviews" button that gives you access to moderating peoples reviews, click Plugins on the left bar, then click "Edit" on the line for WP Customer Reviews. That will bring up the code that you need to look though. Scroll down until you reach this section:

    /* keep out of admin file */
    function addmenu() {
    add_options_page('Customer Reviews', '<img src="' . $this->getpluginurl() . 'star.png" /> Customer Reviews', 'manage_options', 'wpcr_options', array(&$this, 'admin_options'));
    add_menu_page('Customer Reviews', 'Customer Reviews', 'edit_others_posts', 'wpcr_view_reviews', array(&$this, 'admin_view_reviews'), $this->getpluginurl() . 'star.png', 50); /* 50 should be underneath comments */

    Where it has the number 50, you should change it to something else. I chose 45 and it worked out for me. [My first attempt was 60, but then the "Appearance" button disappeared.] Hopefully this might help someone someday. I had to find it for myself, but now you don't.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic