WordPress.org

Ready to get started?Download WordPress

Forums

WP Code Prettify
[resolved] Patch for depricated has_cap argument (3 posts)

  1. ydm
    Member
    Posted 1 year ago #

    Hello!

    Thanks for your plugin, it's really great!
    One small thing is that it's throwing and error message when used with newer versions of WP. The problem is that the $user->has_cap method is being called with depricated int argument while setting up the settings page (wp-code-prettify-page.php at line 156).

    Here is a tiny patch for that file that solves the problem:
    http://4web.bg/wp-content/plugins/wp-code-prettify/patch.txt

    http://wordpress.org/extend/plugins/wp-code-prettify/

  2. Soli
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for your patch.

    new version is released.

    please let me know if it works or not.

  3. ydm
    Member
    Posted 1 year ago #

    It's working great! Thank you!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.