WordPress.org

Ready to get started?Download WordPress

Forums

WP Calendar
[resolved] Problem with Java and Ajax (26 posts)

  1. Ymmmot
    Member
    Posted 3 years ago #

    When I am in the preferences of wp-calendar or writing a new post, the media-buttons (add picture/video/...) dont run. And I can't enter a tag, too. I think its a Java-Ajax-problem, but I dont really know.

  2. Greg Rickaby
    Member
    Posted 3 years ago #

    On the WP Calendar options screen (down at the bottom) there are some toggle switches to disable jQuery. Try those.

  3. Ymmmot
    Member
    Posted 3 years ago #

    Thank you but it doesn't work. :(

  4. Ymmmot
    Member
    Posted 3 years ago #

    I needed to deactivate the plugin. It crashes my whole blog! No way to run JQuery. Nothing run...

  5. faebu
    Member
    Plugin Author

    Posted 3 years ago #

    It crashes my whole blog!

    what crashes? a few more details would be great.

    wp calendar uses some javascript libraries, which could cause your problems. But, all the basic libraries (like jQuery) aren't loaded directly, but loaded the safe and recommended way.

    this sounds more like a conflict with another plug-in or your theme which does not load the libraries, how it should and how it's recommended.

  6. Ymmmot
    Member
    Posted 3 years ago #

    As I said. Can't write tags, the "add-media-buttons" at the top of text-field (where you write a post) don't work. When I am in the preferences-wp-calendar, I can't click on the little arrows next to the other links (like "Users", "Plugins", "Tools" etc.)... There are the plugins I use: link.

  7. faebu
    Member
    Plugin Author

    Posted 3 years ago #

    does it work, when deactivating wp calendar plugin?
    does it work, when deactivating all plug-ins expect the wp calendar plugin?

  8. Ymmmot
    Member
    Posted 3 years ago #

    does it work, when deactivating wp calendar plugin?

    Yes.

    does it work, when deactivating all plug-ins expect the wp calendar plugin?

    Dunno. I must go to work now. I'll try it today evening and then I'll post the result here.

    Greetings

  9. naffets92
    Member
    Posted 3 years ago #

    I have the same problem. It worked in wordpress 3.0 but when I upgraded to 3.1 not anymore.

    I deactivate all the plugins except the wp calender. The 'insert media' buttons don't work.

    I activate all the plugin except the wp calendar. The 'insert media' buttons work!

    I deactivate all the plugins and the insert media buttons work!

    I disabled Loading of jQuery library / Loading of jQuery UI library and Loading of FullCalendar files. It doesn't work.

    I tried different browsers. It don't help.

  10. Ymmmot
    Member
    Posted 3 years ago #

    Yes. That is what I've already mentioned...

  11. Ymmmot
    Member
    Posted 3 years ago #

    @ faebu: Some idea whats the reason for this problem? I really want to use your cool calendar-plugin!

  12. faebu
    Member
    Plugin Author

    Posted 3 years ago #

    wasn't at home the last 2 days and couldn't analyze it. in my installations it works like a charm, but i'm going to analyze your problems this evening.

  13. Ymmmot
    Member
    Posted 3 years ago #

    That's good. I'm curious!!!

  14. faebu
    Member
    Plugin Author

    Posted 3 years ago #

    i couldn't reproduce the problem with the media buttons. but i found some other problems with my scripts, which was responsible for the menu problem. maybe the problem was the same.

    could you test again and report.

  15. naffets92
    Member
    Posted 3 years ago #

    Hi Faebu,

    I'm sorry but it still doesn't work.
    I downloaded the new version and activated it again, but the buttons don't work.

    I will try something for you.
    I'm going to download: http://www.usbwebserver.net/ ..
    On this server I'm also going to install wordpress and (only) WP Calender.
    Maybe my hosting is the problem.

    I keep you posted!

  16. naffets92
    Member
    Posted 3 years ago #

    Okay,

    This is very strange.
    A while ago I created a wordpress website with 3.0 (with usb webserver).
    I also use WP Calender. This works fine!

    Okay well. Now I have upgraded this wordpress website to 3.1.
    The plugin WP calender: current version was 1.2.4.
    This works fine! The insert media buttons in a post work!

    After that I upgraded the WP Calender plugin to the newest version..
    The insert media buttons don't work anymore.
    When I upgraded it, It gaves an announcement:
    I had to reactivate the plugin.

    Now I am going to try the 1.2.4 version of your plugin on my wordpress 3.1 website. Maybe this will work.

  17. naffets92
    Member
    Posted 3 years ago #

    Third message (i'm sorry).

    I want to delete the 1.4.2. version (wordpress 3.1 // usb webserver) but I get this error:

    Fatal error: Call to undefined function remove_option() in C:\Users\Steffan\Desktop\Pro Rege\root\wp-content\plugins\wp-calendar\fsCalendar.php on line 1749

    ///

    Update:

    I deleted the plugin in my root folder.
    After that I download the WP Calender 1.2.4 version.
    This works! The insert media buttons work.

  18. Ymmmot
    Member
    Posted 3 years ago #

    So. Now I've update to 1.4.2. When I'm in the preferences-calendar, everything is fine. When I create a now post, I can't dopdown the menus on the left. The insert-media-buttons work. But I still can't write tags...

  19. faebu
    Member
    Plugin Author

    Posted 3 years ago #

    i still cannot reproduce the problem. is there anybody who uses firefox w. firebug and can see a javascript error?

    to find out what the problem is i need more detailen information:

      - the url, when writing a post
      - what does exactly not work (media button not working can mean different things, does it open the dialog or not? is there just a single problem within the media dialog? Same for tags...
      - please also check if the problem persist if you deactivate all plugins except wp calendar
      - please check if there are any javascript errors (please try firefox w firebug add-on)
      - which language is your installation using?

    thx in advanced.

  20. Ymmmot
    Member
    Posted 3 years ago #

    what does exactly not work (media button not working can mean different things, does it open the dialog or not? is there just a single problem within the media dialog? Same for tags...

    it doesn't open the dialog. when i click on the add-picture-button, nothing happens. when i click into the field for the tags, on the one hand i can write a tag, but on the other hand the gray text in its background doesn't disappears and the dialog where you can choose one of the existing tags doesn't appear, too.

    please check if there are any javascript errors (please try firefox w firebug add-on)

    i use google chrome, where the developer modus is integrated (its the same like firebug). there are no errors displayed when i open a new add-post-page.

    which language is your installation using?

    i use the german language-pack.

    please also check if the problem persist if you deactivate all plugins except wp calendar

    it also doesn't works when i deactivate all my other plugins.

  21. faebu
    Member
    Plugin Author

    Posted 3 years ago #

    i just released an update. it should fix the problem

  22. naffets92
    Member
    Posted 3 years ago #

    He Faebu.. It works! thank you.

  23. Ymmmot
    Member
    Posted 3 years ago #

    He Faebu.. It works! thank you.

    Dito. It works now. Thank you very much!!! What was the reason for the problem?

  24. faebu
    Member
    Plugin Author

    Posted 3 years ago #

    solution was very simple. i couldn't reproduce it because i allways edited a post instead of adding an new one.

    because of wp 3.1 i had load other libraries for the editor (for wp event description) and i did some code loading optimization to make sure the necessary libraries are only loaded when they are really needed.

    this caused the problem, because one library wasn't loaded and break some of the wp standard stuff.

  25. Ymmmot
    Member
    Posted 3 years ago #

    Ah ok buddy. I hope you will continue developing the wp-calendar-plugin! It's a very important plugin for my blog.

    Greets

  26. Tkirbs
    Member
    Posted 3 years ago #

    This kind of goes along with what is being discussed. But I am using the wp calendar on a site as well. I am using the widget as a primary widget, but i am also using secondary "Text" widgets as well.

    With the wp-calendar plugin activated I cannot edit or add new text widgets. The save icon just keeps spinning in circles. I have disable the Loading of jQuery library, Loading of jQuery UI library,Loading of FullCalendar files and it still does not work. The only way i can add/edit text widgets is by deactivating the wp-calendar plugin.

    I really like this plugin because i can do what i need it to do, but I also need to work so that i can add/edit text widgets as well. Any insight on this would be greatly appreciated. This is happening on WordPress 3.0.4. Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic