WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Bit.ly] Support for the 3.0 shortlink API (4 posts)

  1. Samuel Wood (Otto)
    Tech Ninja
    Posted 4 years ago #

    Any plan to make the plugin support the new WordPress 3.0 Shortlink API functionality?

    All you have to do is to basically add a filter handler into your plugin and attach it to the get_shortlink filter.

    See here: http://core.trac.wordpress.org/browser/trunk/wp-includes/link-template.php#L2138

    If you do that, then themes and plugins and such will be able to use your shortlinks automatically.

    http://wordpress.org/extend/plugins/wp-bitly/

  2. Mark Waterous
    Member
    Posted 4 years ago #

    Hey Otto,

    So busy that I didn't see your post until just now. :) I actually wrote about this on my blog here: http://mark.watero.us/2010/04/wordpress-3-short-links/

    To summarize, I definitely plan on supporting the API and have already been poking around under the hood getting it ready to do so. WordPress 3.0 hasn't ceased to impress me.

  3. jeromeparadis
    Member
    Posted 4 years ago #

    Seems like delayedinsanity's blog is not longer maintained.

    Anyway, I wrote some code to make it work and wrote a post explaining how to integrate the WP Bit.ly plugin with WordPress 3.0's shortlink feature.

    You can find my article here: Integrating bit.ly with WordPress 3.0 Shortlinks Support

    Cheers.

  4. Mark Waterous
    Member
    Posted 4 years ago #

    It's not that I don't maintain it, it's just that I don't write anything in it. I hardly remember that it exists most days. :)

    The plugin has been updated for WP 3.0 support and should maintain backwards compatibility on 2.9.2 for those who are slower to upgrade. If during the course of writing your article and playing with the plugin you have any suggestions for improvements or new features, fire away!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags