WordPress.org

Ready to get started?Download WordPress

Forums

WP Biographia
[resolved] Widget appears without information in sidebar (18 posts)

  1. Dr. Moriarty
    Member
    Posted 1 year ago #

    First of all, thank you for this powerful and useful plugin!

    For my main website (alanwindhausen.com), I'd like to use WP Biographia to include an 'About Alan' short-biography in the sidebar. My issue is that I cannot get any biography information, gravatar, or user name to appear in the sidebar. The information is being pulled for 'Display on Individual Pages' but it doesn't seem to translate over to the sidebar.

    I do have two users listed on the website (just so that I can have both my accounts tied together), but one is an admin while the other is a subscriber. I've changed the subscriber to be excluded from the plugin.

    I've included some screenshots of the settings I've changed for WP Biographia, as well:
    Widget
    Page Exclusions
    Style
    Display
    Content (1)
    Content (2)

    I have v.3.2.1 of the plugin, am running WordPress 3.4.2 using the free version of the Startup Theme v.1.0.1

    http://wordpress.org/extend/plugins/wp-biographia/

  2. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    Your settings for the plugin and widget look fine to me, although the plugin's admin settings are only applicable for displaying the Biography Box either automagically within The Loop or via the plugin's shortcode in configured mode.

    Do you have Show Avatars enabled under Dashboard / Settings / Discussion? Also, does your user profile have the shorter biography text actually set?

    I'm assuming your theme is StartupWP ... ? I've installed this theme locally and the plugin's widget is working fine for me so I don't think this is a theme issue.

    -Gary

  3. Dr. Moriarty
    Member
    Posted 1 year ago #

    Thank you for the quick reply! I did enable Avatars (having followed through your setup guide on your website), and have the shorter biography filled out. Both appear on my non-landing pages - you can see this on http://alanwindhausen.com/assignments/

    I am, in fact, using StartupWP.

    Today I tried deleting the plugin and reinstalling, but I'm still in the same boat. I also played with adding dummy information for my other user account, and making that user an admin and even deleting that user - but this changed nothing. The widget shows 'contributors', even though I only have one user one the site at this point, so it's assuming the site has multiple writers. Any ideas on where to check next?

  4. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    From looking at the code that's in the sidebar of your site, I can see that the widget is definitely running, but for some reason, it thinks there's either no post content to pull a user from and thus display the biography or that there's no information on that user, or users, available.

    From digging around on your site a little bit more, it looks like your landing page (http://alanwindhausen.com/) isn't an archive of posts but is a static page ... is that correct? This could be the root cause of the issue.

    But even if that's the case, it doesn't explain why your assignments page (http://alanwindhausen.com/assignments/) isn't showing the widget's output.

    So I'm wondering whether you'd be willing to put up a debug version of the widget on your site, providing your web host allows you access to the PHP error log? That way I could insert some tracing messages to see precisely what's happening in the widget.

    -Gary

  5. Dr. Moriarty
    Member
    Posted 1 year ago #

    My landing page is a static page, yes. I do have full access to my files, and added a php_error log on my WP-config.php file, which I have outputting to a separate file. Opening the site in a different browser with no cache of the site, I haven't seen any errors added to the log, but I'd be happy to insert some tracing messages as well (though I might need to be pointed in the right direction for where in the plugin php file using the WordPress editor).

  6. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    Don't use the WordPress editor to modify plugin files; if you do and the plugin is active, then WordPress will block the plugin and you'll need to uninstall/reinstall. It's a nasty gotcha.

    I'll provide a debug enabled version of the plugin's widget file for you, which you can drop straight into your install. I just need to write it now! As it's the weekend now, give me a couple of days; I should have it together by Monday.

    -Gary

  7. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    So I've knocked up a debug tracing version of the widget this morning over coffee. You'll find it here: https://gist.github.com/3883861

    1. Download the debug version from here:
      https://gist.github.com/gists/3883861/download
    2. Copy the original widget code to another file
    3. Upload the debug version to your server
    4. Rename the debug version to the original version's name

    If you have shell access on your server, the commands will look something like this (YMMV depending on your hosting environment)

    $ cd 'your-web-host-root'/public_html/wp-content/plugins/wp-biographia/includes
    $ cp wp-biographia-widget.php wp-biographia-widget.php.save
    $ wget https://raw.github.com/gist/3883861/2a354af9d540fd8ec05046b590223395d806b731/wp-biographia-widget-debug.php
    $ mv wp-biographia-widget-debug.php wp-biographia-widget.php

    If you only have FTP access on your server, you can do the same thing via an FTP client.

    Now access a page on your site in your browser and check your PHP error log, you should see something like the following ... this is the debug trace I'm interested in.

    [13-Oct-2012 08:19:25 UTC] WP_BiographiaWidget::widget++
    [13-Oct-2012 08:19:25 UTC] Query returned 10 posts
    [13-Oct-2012 08:19:25 UTC] Found 1 users in 10 posts
    [13-Oct-2012 08:19:25 UTC] Creating Biography Box for user ID 2
    [13-Oct-2012 08:19:25 UTC] WP_BiographiaWidget::display++
    [13-Oct-2012 08:19:25 UTC] posts: 333
    [13-Oct-2012 08:19:25 UTC] posts_url: http://locallive:8888/author/gary/
    [13-Oct-2012 08:19:25 UTC] avatar_size: 100
    [13-Oct-2012 08:19:25 UTC] bio: 1369 chars
    [13-Oct-2012 08:19:25 UTC] short_bio: 147 chars
    [13-Oct-2012 08:19:25 UTC] email: gary@vicchi.org
    [13-Oct-2012 08:19:25 UTC] name_options: display-name
    [13-Oct-2012 08:19:25 UTC] name_prefix is set: About
    [13-Oct-2012 08:19:25 UTC] show_about_link is set
    [13-Oct-2012 08:19:25 UTC] show_avatar is set
    [13-Oct-2012 08:19:25 UTC] show_bio is set
    [13-Oct-2012 08:19:25 UTC] short_bio is set
    [13-Oct-2012 08:19:25 UTC] WP_BiographiaWidget::display--
    [13-Oct-2012 08:19:25 UTC] Emitting 663 chars to browser
    [13-Oct-2012 08:19:25 UTC] WP_BiographiaWidget::widget--

    ... let me know how you get on.

    -Gary

  8. Dr. Moriarty
    Member
    Posted 1 year ago #

    Thank you for all this work! The debug version should be up and live, and I've been loading the site on a couple of computers to try and generate the logs.

    Apologies for my php-inexperience, but I do not believe the widget is outputting the errors to any log that I have set up (or, more likely, any log that I know where to access).

    I have a 'php-error.log' file on my home/<username> of the server, but that file remains empty. I also installed Error log Monitor as a dashboard plugin, but that too has an empty log. Do I need to create a separate log file somewhere for the wp-biographia-widget.php to dump to?

    ----

    On the other side of things, I ran some more tests regarding the static landing page. I changed the site to have a landing page of posts (even though there are no posts to speak of besides Hello World), and the widget had two sections: a 'Written By' (empty) and a 'About Alan' (with avatar, but no biography). This is only on the landing page. The other pages still show a blank 'contributors' section in the widget with no other data.

    I went back to the widget settings, and changed it to show BOTH 'Show User's Short Biography' and 'Show User's Biography' - and the text in the from the short section appeared in the widget (but only the short biography, not the long as well...)! The text from the long biography appeared in the plugin box at the end of the posts.

    I then went BACK to the widget settings, turned OFF 'Show User's Biography' (leaving only 'Show User's Short Biography' checked), and the avatar still appeared but NO text from EITHER biography appeared.

    I currently have the widget with both the short and long biographies checked, and have left the posts landing page up on alanwindhausen.com, if you would like to see.

    Here is the colophon information as well:

    [wp_biographia_installed] => on
    [wp_biographia_version] => 321
    [wp_biographia_style_bg] => #FFEAA8
    [wp_biographia_style_border] => top
    [wp_biographia_display_front_posts] => on
    [wp_biographia_display_archives_posts] => on
    [wp_biographia_display_author_archives_posts] => on
    [wp_biographia_display_category_archives_posts] => on
    [wp_biographia_display_date_archives_posts] => on
    [wp_biographia_display_tag_archives_posts] => on
    [wp_biographia_display_posts] => on
    [wp_biographia_display_pages] => on
    [wp_biographia_display_feed] =>
    [wp_biographia_display_location] => bottom
    [wp_biographia_content_prefix] => About
    [wp_biographia_content_name] => first-last-name
    [wp_biographia_content_authorpage] =>
    [wp_biographia_content_image] => on
    [wp_biographia_content_image_size] => 100
    [wp_biographia_content_bio] => on
    [wp_biographia_content_icons] =>
    [wp_biographia_content_alt_icons] =>
    [wp_biographia_content_icon_url] =>
    [wp_biographia_content_email] => on
    [wp_biographia_content_web] =>
    [wp_biographia_content_twitter] =>
    [wp_biographia_content_facebook] =>
    [wp_biographia_content_linkedin] =>
    [wp_biographia_content_googleplus] => on
    [wp_biographia_content_delicious] =>
    [wp_biographia_content_flickr] => on
    [wp_biographia_content_picasa] =>
    [wp_biographia_content_vimeo] =>
    [wp_biographia_content_youtube] =>
    [wp_biographia_content_reddit] =>
    [wp_biographia_content_posts] => extended
    [wp_biographia_content_link_target] => _self
    [wp_biographia_content_link_nofollow] =>
    [wp_biographia_admin_new_users] =>
    [wp_biographia_admin_hide_profiles] =>
    [wp_biographia_category_exclusions] =>
    [wp_biographia_post_exclusions] =>
    [wp_biographia_global_post_exclusions] =>
    [wp_biographia_page_exclusions] =>
    [wp_biographia_admin_content_priority] => 10
    [wp_biographia_admin_excerpt_priority] => 10
    [wp_biographia_sync_content_wpautop] => on
    [wp_biographia_sync_excerpt_wpautop] => on

  9. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    Apologies for my php-inexperience, but I do not believe the widget is outputting the errors to any log that I have set up (or, more likely, any log that I know where to access).

    I have a 'php-error.log' file on my home/<username> of the server, but that file remains empty. I also installed Error log Monitor as a dashboard plugin, but that too has an empty log. Do I need to create a separate log file somewhere for the wp-biographia-widget.php to dump to?

    I configure PHP logging from my php.ini file; the directives I currently have (and which are working just fine) are these ...

    error_reporting  =  E_ALL
    display_errors = Off
    display_startup_errors = Off
    log_errors = On
    log_errors_max_len = 1024
    ignore_repeated_errors = Off
    track_errors = Off
    error_log = "/Applications/MAMP/logs/php_error.log"

    ... you'll need to edit the error_log directive to the path to wherever you want your log file to reside. If you don't have access to your php.ini you can do the same thing from within your wp-config.php by using the @ini_set directive along the lines of

    @ini_set ('error_reporting', 'E_ALL');

    ... repeating @ini_set for each of the above directives.

    I went back to the widget settings, and changed it to show BOTH 'Show User's Short Biography' and 'Show User's Biography' - and the text in the from the short section appeared in the widget (but only the short biography, not the long as well...)! The text from the long biography appeared in the plugin box at the end of the posts.

    I then went BACK to the widget settings, turned OFF 'Show User's Biography' (leaving only 'Show User's Short Biography' checked), and the avatar still appeared but NO text from EITHER biography appeared.

    Looks like there's a bit of confusion over the widget settings (to be fair, I could make this a bit clearer in the documentation).

    Show User's Biography is the master control for whether the widget displays a user's biography text. Show User's Short Biography controls whether the full biography or the short biography is to be used. If Show User's Biography is not checked, then Show User's Short Biography will have no effect as the biography text is turned off.

    If you specify that the short biography is to be displayed and there is no short biography associated with the user's profile, then nothing for the biography text will be displayed.

    -Gary

  10. Dr. Moriarty
    Member
    Posted 1 year ago #

    Okay, I get how the widget 'show biography' toggles work now, and have both checked on. That experiment was a bit of a detour, then.

    Alright, back to the error logs: Double, triple, and quadruple checking the error log setup in php.ini, wp-config.php, and using that error-log widget, my error log file is still empty. For some reason, nothing is being left in there - looking over the debug widget file you put on github, it looks like it should be outputting the settings (like the debug trace example you posted above), correct? If it's not outputting those, would that imply the widget-code is not being fully called upon, for some reason?

  11. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    ... and you've definitely put the debug widget source file in the correct location ... /wp-content/plugins/wp-biographia/includes/ and renamed it from wp-biographia-widget-debug.php to wp-biographia-widget.php ... ?

    Do you have any caching plugins installed and active that might be serving up an older version of the page? Have you tried deactivating all plugins other than WP Biographia?

    -Gary

  12. Dr. Moriarty
    Member
    Posted 1 year ago #

    Yep, Nope, and Yep.

    Source file is in the right spot and renamed, there are no caching plugins, and all other plugins are currently deactivated.

    I greatly appreciate all the time you are taking on this - if it at any point is beginning to be too much, please let me know. Though I would prefer the widget and though I am game to keep work to find and fix the source of this error if you are, I can content myself with using the biography display on the pages rather than the widget for the time being, if needed.

  13. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    So I've tried out the widget using your theme and it works for me no problem. So let's try a slightly different tack. Have you modified the theme at all or is the version up on your site as downloaded? If so, I'll take the settings that I have working and note them down and see if we can't get your site configured precisely the way mine is.

    -Gary

  14. Dr. Moriarty
    Member
    Posted 1 year ago #

    I haven't manually modified the code at all. The only changes have been the in-dashboard options (changing logo image, background color, site tagline).

    Beyond that, I have a static landing page and comments turned on new posts.

  15. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    I've just put together a clean WordPress install and imported the posts from my live site into that install. The site is running your Startup WP theme, plus v3.2.1 of WP Biographia with the out of the box settings. There's no other plugins active. I have 3 users defined, admin, gary and editor and I've just knocked together a quick garbage post for the editor account so there's two users active on the install with posts assigned to them.

    It all seems to work as expected; see the screen grab of the landing page here: http://imgur.com/Goyjz

    The plugin's dashboard settings are out of the box; I've made no configuration changes at all.

    The theme's settings are the same ... I haven't configured a static landing page ... yet.

    The plugin's widget settings are also out of the box; you can see a screen grab of them here: http://imgur.com/n5BY9 - note that I've put the widget into the Sidebar Widget Area, not the theme's Left or Right Sidebar Area.

    The plugin's settings and options are, as previously mentioned, out of the box, but I'll reproduce them here, as reported on the Colophon tab so you can compare them. First, the Plugin Configuration Settings ...

    Array
    (
        [wp_biographia_installed] => on
        [wp_biographia_version] => 321
        [wp_biographia_style_bg] => #FFEAA8
        [wp_biographia_style_border] => top
        [wp_biographia_display_front_posts] => on
        [wp_biographia_display_archives_posts] => on
        [wp_biographia_display_author_archives_posts] => on
        [wp_biographia_display_category_archives_posts] => on
        [wp_biographia_display_date_archives_posts] => on
        [wp_biographia_display_tag_archives_posts] => on
        [wp_biographia_display_posts] => on
        [wp_biographia_display_pages] => on
        [wp_biographia_display_feed] =>
        [wp_biographia_display_location] => bottom
        [wp_biographia_content_prefix] => About
        [wp_biographia_content_name] => first-last-name
        [wp_biographia_content_authorpage] => on
        [wp_biographia_content_image] => on
        [wp_biographia_content_image_size] => 100
        [wp_biographia_content_bio] => on
        [wp_biographia_content_icons] =>
        [wp_biographia_content_alt_icons] =>
        [wp_biographia_content_icon_url] =>
        [wp_biographia_content_email] => on
        [wp_biographia_content_web] => on
        [wp_biographia_content_twitter] => on
        [wp_biographia_content_facebook] => on
        [wp_biographia_content_linkedin] => on
        [wp_biographia_content_googleplus] => on
        [wp_biographia_content_delicious] =>
        [wp_biographia_content_flickr] =>
        [wp_biographia_content_picasa] =>
        [wp_biographia_content_vimeo] =>
        [wp_biographia_content_youtube] =>
        [wp_biographia_content_reddit] =>
        [wp_biographia_content_posts] => extended
        [wp_biographia_content_link_target] => _self
        [wp_biographia_content_link_nofollow] =>
        [wp_biographia_admin_new_users] =>
        [wp_biographia_admin_hide_profiles] =>
        [wp_biographia_category_exclusions] =>
        [wp_biographia_post_exclusions] =>
        [wp_biographia_global_post_exclusions] =>
        [wp_biographia_page_exclusions] =>
        [wp_biographia_admin_content_priority] => 10
        [wp_biographia_admin_excerpt_priority] => 10
        [wp_biographia_sync_content_wpautop] =>
        [wp_biographia_sync_excerpt_wpautop] =>
    )

    ... and the User Configuration Settings ...

    Array
    (
        [1] => Array
            (
                [ID] => 1
                [user_login] => admin
                [wp_biographia_suppress_posts] =>
                [wp_biographia_suppress_pages] =>
            )
    
        [4] => Array
            (
                [ID] => 4
                [user_login] => editor
                [wp_biographia_suppress_posts] =>
                [wp_biographia_suppress_pages] =>
            )
    
        [2] => Array
            (
                [ID] => 2
                [user_login] => gary
                [wp_biographia_suppress_posts] =>
                [wp_biographia_suppress_pages] =>
            )
    
    )

    Let me know how you get on ...

    -Gary

  16. Dr. Moriarty
    Member
    Posted 1 year ago #

    I compared your colophon data to mine, and changed what settings I had different to match. I still was having the same issue.

    So I decided to do something a bit more drastic - I did a complete reinstall of WordPress on the site, and then added my WordPress account as an admin. I create a couple dummy posts and filled in some dummy data in for my biography.

    I still had the same problems:
    Front Page (Posts page, not static)
    http://imgur.com/A4M0J,q56WL

    Secondary Page
    http://imgur.com/A4M0J,q56WL#1

    These were the settings under my new install.

    Array
    (
        [wp_biographia_installed] => on
        [wp_biographia_version] => 321
        [wp_biographia_style_bg] => #FFEAA8
        [wp_biographia_style_border] => top
        [wp_biographia_display_front_posts] => on
        [wp_biographia_display_archives_posts] => on
        [wp_biographia_display_author_archives_posts] => on
        [wp_biographia_display_category_archives_posts] => on
        [wp_biographia_display_date_archives_posts] => on
        [wp_biographia_display_tag_archives_posts] => on
        [wp_biographia_display_posts] => on
        [wp_biographia_display_pages] => on
        [wp_biographia_display_feed] =>
        [wp_biographia_display_location] => bottom
        [wp_biographia_content_prefix] => About
        [wp_biographia_content_name] => first-last-name
        [wp_biographia_content_authorpage] => on
        [wp_biographia_content_image] => on
        [wp_biographia_content_image_size] => 100
        [wp_biographia_content_bio] => on
        [wp_biographia_content_icons] =>
        [wp_biographia_content_alt_icons] =>
        [wp_biographia_content_icon_url] =>
        [wp_biographia_content_email] => on
        [wp_biographia_content_web] => on
        [wp_biographia_content_twitter] => on
        [wp_biographia_content_facebook] => on
        [wp_biographia_content_linkedin] => on
        [wp_biographia_content_googleplus] => on
        [wp_biographia_content_delicious] =>
        [wp_biographia_content_flickr] =>
        [wp_biographia_content_picasa] =>
        [wp_biographia_content_vimeo] =>
        [wp_biographia_content_youtube] =>
        [wp_biographia_content_reddit] =>
        [wp_biographia_content_posts] => extended
        [wp_biographia_content_link_target] => _self
        [wp_biographia_content_link_nofollow] =>
        [wp_biographia_admin_new_users] =>
        [wp_biographia_admin_hide_profiles] =>
        [wp_biographia_category_exclusions] =>
        [wp_biographia_post_exclusions] =>
        [wp_biographia_global_post_exclusions] =>
        [wp_biographia_page_exclusions] =>
        [wp_biographia_admin_content_priority] => 10
        [wp_biographia_admin_excerpt_priority] => 10
        [wp_biographia_sync_content_wpautop] =>
        [wp_biographia_sync_excerpt_wpautop] =>
    )

    and users:

    Array
    (
        [3] => Array
            (
                [ID] => 3
                [user_login] => admin
                [wp_biographia_suppress_posts] =>
                [wp_biographia_suppress_pages] =>
            )
    
        [2] => Array
            (
                [ID] => 2
                [user_login] => awindhausen
                [wp_biographia_suppress_posts] =>
                [wp_biographia_suppress_pages] =>
            )
    
    )

    I went back and added the debug widget code and the code to my php.ini file to output it to my error file, but that remained empty too.

    From all this, it seems that there is a disconnect somewhere in my server files. While there is a small glitch with having a static front page, the bulk of this problem definitely lies on my side somewhere, and without a debug trace, I'm not sure where.

    Thank you very much for all the help you've offered, but I think I need to get the bug traced on my end somehow - when I get a chance, I'll have one of my code buddies look over my server setup and see what about my files on inmotion's servers is causing all this trouble.

    For the mean time, I'll keep the page-biography from WP Biographia, and play with it more when I have time.

    Thank you again!

  17. Dr. Moriarty
    Member
    Posted 1 year ago #

    I have linked to your plugin on my site (which is not restored sans-widget for now):
    http://alanwindhausen.com/links/

    I greatly appreciate your help and will post again if I find the source of my trouble.

  18. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks Alan ... I agree that we seem to be at an impasse here. Let me know how you get on and if you need help with your server configuration please get in touch off forum.

    -Gary

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic