WordPress.org

Ready to get started?Download WordPress

Forums

WP Biographia
[resolved] More Posts link goes to homepage (13 posts)

  1. sjp12
    Member
    Posted 1 year ago #

    Hi there... great plugin, thank you! The only problem that I'm having is that for each author when you click More Posts it just brings you to the home page to the author's posts. I'd really like to get that working.

    Any suggestions? I'm running version 3.1.0.

    http://wordpress.org/extend/plugins/wp-biographia/

  2. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    Hi ...

    when you click More Posts it just brings you to the home page to the author's posts

    Sorry ... not quite sure what you mean. Does the More Posts link take you to your blog's home URL or the author's archive URL (/author/xxx) ?

    -Gary

  3. sjp12
    Member
    Posted 1 year ago #

    Gary, I'm sorry, not enough coffee when I wrote that sentence. What I meant was,when I click More Posts in the author box in the bottom of the post, it redirects to the home page instead of to a list of posts by that author.

    Thanks

  4. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    That's really odd. Can I see your current configuration for the plugin? It's under the "Colophon" tab in the plugin's Settings & Options.

    -Gary

  5. sjp12
    Member
    Posted 1 year ago #

    Array
    (
    [wp_biographia_installed] => on
    [wp_biographia_version] => 310
    [wp_biographia_style_bg] => #e0faf5
    [wp_biographia_style_border] => top
    [wp_biographia_display_front] =>
    [wp_biographia_display_archives] =>
    [wp_biographia_display_posts] => on
    [wp_biographia_display_pages] =>
    [wp_biographia_display_feed] =>
    [wp_biographia_display_location] => bottom
    [wp_biographia_content_prefix] => About Author
    [wp_biographia_content_name] => first-last-name
    [wp_biographia_content_authorpage] => on
    [wp_biographia_content_image] => on
    [wp_biographia_content_image_size] => 50
    [wp_biographia_content_bio] => on
    [wp_biographia_content_icons] =>
    [wp_biographia_content_alt_icons] =>
    [wp_biographia_content_icon_url] =>
    [wp_biographia_content_email] =>
    [wp_biographia_content_web] => on
    [wp_biographia_content_twitter] => on
    [wp_biographia_content_facebook] => on
    [wp_biographia_content_linkedin] => on
    [wp_biographia_content_googleplus] => on
    [wp_biographia_content_delicious] =>
    [wp_biographia_content_flickr] =>
    [wp_biographia_content_picasa] =>
    [wp_biographia_content_vimeo] =>
    [wp_biographia_content_youtube] =>
    [wp_biographia_content_reddit] =>
    [wp_biographia_content_posts] => basic
    [wp_biographia_content_link_target] => _blank
    [wp_biographia_content_link_nofollow] => on
    [wp_biographia_admin_new_users] =>
    [wp_biographia_admin_hide_profiles] =>
    [wp_biographia_category_exclusions] =>
    [wp_biographia_post_exclusions] =>
    [wp_biographia_global_post_exclusions] =>
    [wp_biographia_page_exclusions] =>
    [wp_biographia_admin_content_priority] => 10
    [wp_biographia_admin_excerpt_priority] => 10
    )

  6. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    That's very odd. I can't see anything in the config that would make this happen. Nor can I replicate this, using your settings, on my local installation.

    Three questions spring to mind ...

    Firstly, does this happen for all your users, or just one or two?

    Secondly, is the Biography Box you're looking at which exhibits this behaviour automagically added to a post by the plugin or is it produced by the plugin's shortcode?

    Thirdly, are there any other plugins that you have which could be interfering with the URL? Such as an SEO plugin for example. Have you tried disabling all plugins, then re-enabling WP Biographia and seeing if it still happens?

    -Gary

  7. sjp12
    Member
    Posted 1 year ago #

    1. It happens for all the users.
    2. The bio box is added by the plugin, not by shortcode.
    3. Using Yoast for SEO. I have not tried to disable all the plugins, but I'll try that this weekend. I do have a ridiculous amount of plugins installed - ones that I use...so I probably need to go in and spend some time looking at that.

    Thanks

  8. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    Do you mean this SEO plugin - http://wordpress.org/extend/plugins/wordpress-seo/ - ?

    If so, I'll install it locally and see whether it's causing this fun and games.

    But at the same time, it's been my experience that this sort of oddness is often caused by two plugins not playing well together. Sadly the only effective way of tracking this down is to disable them all, check the problem doesn't occur (and if it does then it's a bug in my plugin) and then re-enable them one by one until you find the problematic one.

    It's not the most helpful of suggestions but I'm afraid it's pretty much the only way.

    -Gary

  9. sjp12
    Member
    Posted 1 year ago #

    Yes, that's the one! ok, thanks, I will tackle this this weekend.

  10. sjp12
    Member
    Posted 1 year ago #

    It was WordPress SEO - Yoast! Turned it off and it works!

  11. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    Wow. That's good to know. Don't suppose you still have the settings you had configured in the SEO plugin do you? It'd be good to try and replicate this and see what was causing it.

    In the meantime, I'll flag this as resolved.

    -Gary

  12. scottiedogdave
    Member
    Posted 1 year ago #

    there is an option under Other in the Yoast - WordPress - SEO plugin that allows you to turn on/off the Authors archives. By unchecking the "Disable Author Archives option, your Authors page will show up on your site.

    Just an FYI.

  13. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    That's good to know. I'll include a write up of this in the FAQ for the next version of the plugin.

    -Gary

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic