WordPress.org

Ready to get started?Download WordPress

Forums

WP Biographia
[resolved] Author Bio not in sidebar (7 posts)

  1. badgolfer1974
    Member
    Posted 1 year ago #

    Hi, I installed the WP Biographia but cannot seem to have the author bio on the sidebar (right side). I uploaded a pic to wordpress and also wrote in the bio box. I checked my plugin settings and it seems to be correct (display on the front page, etc.). Please help!

    http://TheEducatedSociety.com

    http://wordpress.org/extend/plugins/wp-biographia/

  2. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    Hi ... I'll need a bit more information than this to help. Take a look at http://www.vicchi.org/codeage/wp-biographia/bending-wp-biographia-to-your-will-a-configuration-guide/ and at http://www.vicchi.org/codeage/asking-for-wordpress-plugin-help-and-support-without-tears/ for a start; this will give you a heads up for configuring the plugin and also the sort of information that makes getting help a lot easier.

    I'm not sure what you mean by uploaded a pic to WordPress. The plugin uses the standard WordPress avatar mechanism via Gravatars, so unless you're running another plugin to support locally hosted images then I'm unclear how or what you uploaded.

    Likewise, for wrote in the bio box ... this information needs to be entered as part of your user's WordPress profile. Is this what you did?

    WP Biographia supports a widget that can be dragged to your theme's sidebar, providing your theme uses the standard WordPress sidebar mechanism, as for any other widget. What specific problem are you having here?

    -Gary

  3. badgolfer1974
    Member
    Posted 1 year ago #

    Hi Gary,

    Thank you for being so patient, but I really have no idea what I'm doing. I feel like I've followed everything in your configuration guide:

    1) Now I have an author bio on my homepage (after I dragged the WP biographia widget to the sidebar), which is good, yet no image shows up even when I uploaded a pic on gravatar (even though I have the "Show User's Avatar" box checked.

    2) The line breaks in my author bio is challenging as a layperson who knows nothing about codes. I tried my best, and copied the html code that was recommended to the functions.php, but of course no one ever mentioned "where" in the box to copy it to, other than "just insert it in the functions.php!" (the top? the bottom? there are like 500 lines in that box!) I copied it to the top of the box, updated it, and got strange lines of gibberish on the top of my website, so I took it out.

    3) Finally, I can't seem to remove the search widget from my sidebar, even though I dragged it out of my "active" list to the inactive list. As a result, the search widget takes up space on the right side and makes my author bio column long and narrow. I know this isn't a wp biographia thing, but even with the configuration guide, it's like you need a phd to do this. and I have one lol.

    anything you can do to help me would be great--again, i appreciate your patience.

  4. badgolfer1974
    Member
    Posted 1 year ago #

    by the way, you can see my blog site at http://TheEducatedSociety.com

  5. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    1) Now I have an author bio on my homepage (after I dragged the WP biographia widget to the sidebar), which is good, yet no image shows up even when I uploaded a pic on gravatar (even though I have the "Show User's Avatar" box checked.

    Assuming you're using the standard WordPress avatar mechanism and using Gravatars to provide the avatar image (in other words you're not using another plugin to provide local avatar images or which uses a WordPress API call other than get_avatar()) then this is a 3 stage process. You'll find the full version in this post - http://www.vicchi.org/codeage/wp-biographia/bending-wp-biographia-to-your-will-a-configuration-guide/ - but the quick and dirty version is as follows ...

    1. Sign up for a Gravatar and upload your avatar image. The email address you use to sign up with must be the same as the email address in your WordPress profile.
    2. Enable use of avatars in the WordPress core. From the Dashboard navigate to Settings -> Discussion and under Avatars make sure that Show Avatars is checked under Avatar Display. Make sure you click on Save Changes.
    3. If you're using WP Biographia to add the Biography Box to posts or pages, either automatically or via the shortcode, under Settings -> WP Biographia ->Content, make sure that User's Image is checked and save changes. If you're using the WP Biographia widget, ensure that Show User's Avatar is checked.

    2) The line breaks in my author bio is challenging as a layperson who knows nothing about codes. I tried my best, and copied the html code that was recommended to the functions.php, but of course no one ever mentioned "where" in the box to copy it to, other than "just insert it in the functions.php!" (the top? the bottom? there are like 500 lines in that box!) I copied it to the top of the box, updated it, and got strange lines of gibberish on the top of my website, so I took it out.

    If you add the following, to the end of your theme's functions.php file, which you'll find at /wp-content/themes/your-theme-name/functions.php, just before the closing ?> PHP tag, you'll be able to save line breaks in a user's profile. You can do this either by wrapping the paragraphs in the HTML p tag or by using the HTML br tag.

    remove_filter ('pre_user_description', 'wp_filter_kses');
    add_filter('pre_user_description', 'wp_filter_post_kses');
    add_filter('pre_user_description', 'wptexturize');
    add_filter('pre_user_description', 'wpautop');
    add_filter('pre_user_description', 'convert_chars');
    add_filter('pre_user_description', 'balanceTags', 50);

    3) Finally, I can't seem to remove the search widget from my sidebar, even though I dragged it out of my "active" list to the inactive list. As a result, the search widget takes up space on the right side and makes my author bio column long and narrow. I know this isn't a wp biographia thing, but even with the configuration guide, it's like you need a phd to do this. and I have one lol.

    This probably depends on your theme and whether your theme has a hard coded search widget in the post template files or whether it's using a search widget or not. If one doesn't appear under Appearance -> Widgets then it's probably part of the theme.

    Hope this all helps

    -Gary

  6. badgolfer1974
    Member
    Posted 1 year ago #

    Hallelujah.

    Apparently I had different emails for WordPress and Gravatar.

    As for the line breaks, I followed your very CLEAR instructions (the quick and dirty version). Just remember us newbies literally need to be talked to like 5 year olds. I didn't know where to insert that text in the functions.php before.

    The blog now looks respectable, thanks to you Gary.
    Best,
    Norman

  7. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    Excellent! That's made my morning. Glad you're happy and you have a "respectable" blog!

    -Gary

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags