WordPress.org

Ready to get started?Download WordPress

Forums

WP Better Emails
[resolved] Conflict with Contact 7 Plugin? (8 posts)

  1. AMGill
    Member
    Posted 2 years ago #

    I love your plugin - the emails look great. Thank you. However I notice when a visitor fills out the Contact 7 form on the website the senders email address does not show and therefore the receiver cannot reply. The address in the FROM field is what is set as the default email address. It seems to override what anyone puts as their own address. Is the because Contact Form 7 uses wp()?? Is there any workaround to this?

    http://wordpress.org/extend/plugins/wp-better-emails/

  2. Paul
    Member
    Posted 2 years ago #

    Just want to confirm that I have the exact same problem. Using WP 3.2.1, Contact Form 7 v.3.01 and WP Better Emails 0.2.4.

  3. Paul
    Member
    Posted 2 years ago #

    I've taken a look at the html of the email and the address is there, just not displayed. This is an example of the problem area:

    <tbody>
                              <tr>
                                <td colspan="2" style="border-top: solid 1px #d9d9d9;">
                                  <div style="padding: 15px 0;">From: paul <paul@gmail.com><br />
    Subject: is there a contact address<br />
    <br />
    Message Body:<br />
    test mail<br />
  4. MikeBav
    Member
    Posted 2 years ago #

    I also have this problem with the same plugin versions as Paul.

    I thought checking the 'Use HTML content type' in Contact 7 would make WP Better Emails ignore it, as it's only supposed to change plain text emails. However with this checked, it still appears to send a plain text email via Contact 7, and the email address is still missing. So, I've had to deactivate WP Better Emails for now.

    Thanks Paul for helping us find the contact email address in the source!

  5. Paul
    Member
    Posted 2 years ago #

    MikeBav, I did find a work around for this. Thought I had posted it. It was a long time ago but I think all I had to do was put [your-email] instead of <[your-email]> in the Message body of the contact form.

    i.e. the first line of my message body is:
    From: [your-name] [your-email]

    Try this out, let me know how this works out for you.

  6. MikeBav
    Member
    Posted 2 years ago #

    Paul, thanks - this worked in the email body with [your-name] [your-email], and in the From field still use [your-name] <[your-email]>.

    In WP Better Emails I had the Sender Details filled in at the top where it says 'Set your own sender name and email address.' When this was set, the From address was over-written on the Contact 7 form - so leave this blank.

  7. thatwastaxing
    Member
    Posted 1 year ago #

    Me too. Ended up deactivating WP Better Mails because of the conflict with Contact Form 7.

    Hopefully this plugin gets updated to correct that since I rather like the nicer looking emails ;)

  8. hellonico
    Member
    Plugin Author

    Posted 1 year ago #

    Hi there,

    Sorry for the delay, I had no time to bring support.

    I just tested on a default and fresh WP installation with both plugins activated and everything is working fine. Be sure to NOT check the "Use HTML content type" checkbox in "Contact Form 7".

    • If you don't want the sender name and address to be over written, you must leave the fields (in WP Better Emails) empty.
    • If for any reason, you need to set an sender name and address in WP Better Emails, you can add some extra email headers to your contact form in the "Additional headers" field :
      Reply-to: [your-name] <[your-email]>

      When you'll receive emails from the contact form, although the "from" address and name will be still set to the values in WP Better Emails, when you'll hit "Reply to" in your email client, the "To" field will be filled with the email address typed in the form.

    I guess that solves your problem.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic