WordPress.org

Ready to get started?Download WordPress

Forums

WP-Beautifier
[resolved] Dependancy issue. (4 posts)

  1. Sterling Hamilton
    Member
    Posted 3 years ago #

    Howdy!

    I tried to install the plugin and go the following error:

    Plugin could not be activated because it triggered a fatal error.
    
    Parse error: syntax error, unexpected '&', expecting T_VARIABLE or '$' in /html/wp-content/plugins/wp-beautifier/beautifier.php on line 389

    I looked at the line and basically what it's doing is appending to an array.

    See: http://php.net/manual/en/control-structures.foreach.php

    As of PHP 5, you can easily modify array's elements by preceding $value with &. This will assign reference instead of copying the value.

    So the plugin is PHP5 dependant.

    $ php -v
    PHP 4.4.8

    My server doesn't have it so I cannot use the plugin.

    Just a heads up!

    http://wordpress.org/extend/plugins/wp-beautifier/

  2. Till Krüss
    Member
    Plugin Author

    Posted 3 years ago #

    Thanks for the report, I will make the plugin PHP4 compatible in the next days!

  3. Till Krüss
    Member
    Plugin Author

    Posted 3 years ago #

    Just released 1.3.1, please try to install that version.

  4. Sterling Hamilton
    Member
    Posted 3 years ago #

    Downloading install package from http://downloads.wordpress.org/plugin/wp-beautifier.1.3.1.zip…

    Unpacking the package…

    Installing the plugin…

    Successfully installed the plugin WP-Beautifier 1.3.1.

    Thanks! ^_^

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic