WordPress.org

Ready to get started?Download WordPress

Forums

WP-Ajaxify-Comments
[resolved] Suggestions (17 posts)

  1. saymonz
    Member
    Posted 1 year ago #

    Hi!

    Great plugin! I would only suggest (as I did on my site) to have no timeout on loading message. On my blog (saymonz.net), posting comments is sometimes VERY long with your plugin (up to 15s) and when the loadin disappear, the user have no idea if the posting is done or not.

    Keep up the good work!

    -- saymonz

    http://wordpress.org/extend/plugins/wp-ajaxify-comments/

  2. saymonz
    Member
    Posted 1 year ago #

    It would also be great to change the URL showed in the browser address bar to the direct URL of the just posted comment (with correct anchor). A smooth scrolling to that anchor would be great to.

  3. janjonas
    Member
    Plugin Author

    Posted 1 year ago #

    Hi saymonz,

    thanks for your suggestions.

    Changing of URL and smooth scrolling to the comment will be included in the next release.

    I cannot reproduce any long loading times with my plugin. Could you debug the problem on your site? For example you could use Firebug to see how long the request to wp-comments-post.php takes. The plugin itself does not delay the commenting process with any timeouts.

    Jan

  4. janjonas
    Member
    Plugin Author

    Posted 1 year ago #

    Hi saymonz,

    changing of URL and smooth scrolling to the comment is included in the most recent release (0.1.1).

    Jan

  5. saymonz
    Member
    Posted 1 year ago #

    Hi!

    Great for scrolling and address bar change.

    For thhe long posting issue, I simply have a shitty web host I think. Si keeping the posting message on screen until the comment is effectively posted cannot be a bad idea.

    Also, I noticed that whenever your plugin is activated, the YARPP admin page is all messed up (mouseover help texts showed inline and stuff). This is no big deal (YARPP still usable), but would be great to have this fixed.

    -- saymonz

  6. janjonas
    Member
    Plugin Author

    Posted 1 year ago #

    Hi saymonz,

    thanks for your comment. The problem with YARPP should be resolved in the most recent version 0.1.2 of my plugin.

    Jan

  7. saymonz
    Member
    Posted 1 year ago #

    Yay, no more issue in YARPP! Thanks!

    However, I still have this long posting issue. I already have a posting time about ~10s without your plugin, but when it's activated I have seen as much as 26s (recorded with the Google Chrome inspector)!

    Again, I don't blame your plugin for that, I have a really cheap web hosting (that is widely sufficient for my needs though), it just would be great to have the "Posting comment" message box on screen (no timeout) until another message (confirmation or error) appears. That could be done easily by replacing the line 22 in wp-ajaxify-comments.js with:

    timeout: (type == "loading") ? 0 : 3000,0

    I applied this with success on my blog, but I have to do this modification on each update unless you integrate this directly out of the box :)

    -- saymonz

  8. taifurbau
    Member
    Posted 1 year ago #

    why it takes time to submit a comment(about 15s)? What can I do now? Plz help in details. I'm using Thesis Theme & wordpress 3.3.1.

  9. janjonas
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    your Timeout fix is included in the most recent version (0.2.0).

    @taifurbau: Can you please test, if this bug fix reduces the time needed to submit a comment?

    Regards,
    Jan

  10. saymonz
    Member
    Posted 1 year ago #

    Great, thanks!

    Probably not related but now the fallback redirection is always executed, with Firefox and Chrome.

    Apparently, that's this test who cause the problem :
    if (newCommentForm.length == 0) return wpac_fallback();

    My comment form have the default #commentform id, so I left the option empty and the default value is correctly reported in my page header. I don't know JavaScript well enough to fix it.

  11. janjonas
    Member
    Plugin Author

    Posted 1 year ago #

    Hi saymonz,

    is your blog public available? Which theme are you using?

    Regards,
    Jan

  12. saymonz
    Member
    Posted 1 year ago #

    It's public, on saymonz.net. My theme is JC One Lite. I cant't figure where the problem is.

  13. janjonas
    Member
    Plugin Author

    Posted 1 year ago #

    Hi saymonz,

    thanks again for your comment. Can you please test the new release 0.2.1?

    Regards,
    Jan

  14. saymonz
    Member
    Posted 1 year ago #

    Everything is fine again! Thanks a lot!

  15. taifurbau
    Member
    Posted 1 year ago #

    Thanks, It working good..

  16. taifurbau
    Member
    Posted 1 year ago #

    after upgrading to 0.7.0 from 0.6.1 it is not working. After submit a comment it try to reload the page but it goes to 404 page & the url shows in address bar is the home page url. I'm using wordpress 3.4 & thesis theme. Please give a suggestion ASAP.

  17. janjonas
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,
    could you please send me the debug output of the plugin and a link to your blog to reproduce th problem?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.