WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Ajax Edit Comments] v1.1.5.1 + jQuery 1.4.1 + MSIE Issue (5 posts)

  1. travelvice
    Member
    Posted 4 years ago #

    I know there isn't much hope for getting this answered, but I suppose I should just put it out there and maybe Ronalfy will give me a few moments of his time.

    I'm locked into WP 2.3.1, and with the addition of a new comment form have encountered an issue with v1.1.5.1 when using jQuery 1.4.1 ...but only on MSIE8.

    Here's a screenshot of the problem:[ SCREENSHOT ]

    The edit comments script seems to be working fine under FF and Chrome, but in IE the area is collapsed. I expanded it with a min-height:20px in the CSS file, but it's clear there's no text or functionality in the comment field.

    Ronalfy -- have you seen this before? Maybe you can give me a point in the right direction?

    Cheers,

    //craig

    http://wordpress.org/extend/plugins/wp-ajax-edit-comments/

  2. Ronald Huereca
    Member
    Posted 4 years ago #

    Wowsers, that is an old version. Brings back memories of me being picked on at the playground.

    Try this version of the JS file and see if it works.

    http://pastebin.com/KXZckTJT

    If it doesn't, revert to the old version and leave a post where I can leave a test comment.

  3. travelvice
    Member
    Posted 4 years ago #

    Wonderful to hear from you ronalfy -- I've updated the file (though think it's the same as the version I was using previously in v1.1.5.1 as the 'last modified' date matches).

    Alas, I'm still getting this hiccup. I've re-enabled everything so that you can have a look for yourself to see if anything jumps out at you. [A POST YOU CAN TEST ON]

    Thanks again for the brainpower!

  4. Ronald Huereca
    Member
    Posted 4 years ago #

    Try this:

    Revert back to 1.1.5.1 (no modified files).

    Go into the main plugin file (wp-ajax-edit-comments.php) and edit out line 408
    wp_register_script('jquery', get_bloginfo('wpurl') . '/wp-content/plugins/wp-ajax-edit-comments/js-includes/jquery.js');

    In your theme, there are two references to jQuery:
    http://travelogue.travelvice.com/wp-content/themes/travelogue-2008/jquery-scripts/jquery-1.4.1.min.js
    and
    http://travelogue.travelvice.com/wp-content/themes/travelogue-2008/jquery-scripts/jquery-1.4.1.min.js?ver=6124

    What you want to do is remove both of those references from your header.php file and instead use the wp_enqueue_script function prior to the wp_head() call (also in header.php).

    Would look like this:

    wp_deregister_script('jquery'); //Removes WP's jQuery version
    wp_enqueue_script('jquery','http://travelogue.travelvice.com/wp-content/themes/travelogue-2008/jquery-scripts/jquery-1.4.1.min.js',array(),'1.4.1'); //Loads your own
    wp_head(); //Shown for display purposes only

    I have a feeling doing that will resolve the issue.

  5. travelvice
    Member
    Posted 4 years ago #

    Howdy, thanks for your efforts!

    You should know that already in my header I've got this in place before the call to wp_head:

    <?php
    if ( !is_admin() ) // using a newer version of jQuery will break stuff in WP admin
    {
      wp_deregister_script('jquery');
      wp_enqueue_script('jQuery', 'http://travelogue.travelvice.com/wp-content/themes/travelogue-2008/jquery-scripts/jquery-1.4.1.min.js');
    }
    ?>

    v1.5.1.1 should be what you tested on already, without any modifications.

    Edit Comments is the script that's placing the "?ver=6124" on the end of the script call.

    ***

    I went ahead and implemented the new wp_enqueue_script block and things appear to be working wonderfully (confirmed in MSIE8 & Chrome)! Perhaps my attempt to unregister WP's jQuery wasn't working properly.

    ronalfy -- You've been a great help. I certainly appreciate your time this evening. Thank you.

Topic Closed

This topic has been closed to new replies.

About this Topic